Answered

Can't access Sonos Music Library

  • 8 January 2023
  • 4 replies
  • 267 views

Years ago, I copied all my CDs to a USB thumb drive.  If I look at it with Windows Explorer it shows the usual genre folders (Classical, Rock, etc).  And within genre folders are Album folders, and MP3s for tracks within those.  If I make a copy of that USB drive and plug it into the USB socket in the car it works fine.  I assume all this genre/album/track/artist/composer/etc must have come from metadata on the CDs since I don’t have to do anything to have it work in the car.

In the house I have an Addonics NAS40ESU NAS drive into which I plug said USB drive and set it up as my Sonos S1 music library.  Used to work fine, but perhaps with transitions to new PCs, OS’s (now W11), ISPs, & routers, it quit, and the CA Addonics support line has gone away.  So, since the desktop PC is on 24/7, I plugged the USB drive into it, and replaced my Music Library.  That worked for a while, but again, the configurations have changed and now NG.  On the PC S1 Sonos app I can see and select rooms, albums, etc, but when I select Play Now, it says Unable To Connect to //RC_Geekom / Sonos Music.  Same with the phone app.

Any source except the Music Library works fine, like KDFC on Tune-in, but I’d like to be able to switch from Schubert to Springsteen at will.  I recently spent over an hour with Sonos tech support and did the Let Me Control Your Computer thing.  But no resolution.  I looked at topics suggested, but most look pretty old. 

Appreciate any help reclaiming my trusty old Sonos system.

TIA    Don

icon

Best answer by Ken_Griffiths 8 January 2023, 19:35

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

4 replies

I think you were sharing the drive/library originally using SMBv1 but Windows 11 does not install that protocol by default and so you either need to add the SMB v1 protocol (which can present a small security risk) or you can setup the share again using the http protocol instead using the S1 Sonos controller App for PC and see if that will work for you. See this link

https://support.sonos.com/en-us/article/add-your-music-library-to-sonos

I would suggest setting the computer in question with a ‘fixed’ IP address and try using that address in place of the PC’s netbios name, as it appears from your post that the PC has an underscore in its name and that character might present some issues too with a library share. 

There is a known problem with Sonos accessing music libraries stored on USB drives.

 

I would guess there’s some aspect of a router simulating an NAS’ software that can be challenging, especially when attempting to connect via SMB. 

Matters much improved.  In replacing PC et al, the USB drive ended up plugged into a non-powered USB hub, and apparently has troubles accessing.  By plugging directly into PC music is music improved.  Will see how that lasts.  Can pass on flaky NAS for now.  Thx for replies.

Don