Bug report over Samba share for music library

  • 26 August 2021
  • 5 replies

Hi, this is the simple problem.

i’ve just configured a share over my QNAP NAS through SAMBA sharing protocol, the NAS is updated and SMB is at version 3.
I’ve pointed a major share directory in which, on surface, is visibile the snapshot folder and it start with a @ symbol; the problem consist in the fact that all other folders in that share are NOT VISIBLE in the scanned library from SONOS app, phenomenon that never happened before activating snapshots (so with that virtual folder visible and accessible).
if i point/map directly a subfolder inside the main share showing the @ dir i see everything about what’s inside, i suspect there is some king of problem this special chars … could you investigate?

Thanks in advance


Best answer by Azzola 26 August 2021, 13:36

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

5 replies

Sonos does not currently use SMB v3 - try setting the share to use v1 instead.

sorry, didn’t mentioned that there is back support to v1 v2 v2.1 also over v3 . As mentioned if i point inside a subfolder of the share everything works fine, just on surface there is that problem, i only see the virtual snapshots folder

See if this thread perhaps assists. It mentions limiting SMB to v1 only, if your NAS allows that?…


Badge +20

The AT @ symbol is not wildly supported, can you try amending the share name and try again.

i cannot change that name @recently-snapshot , i could only disable snapshot showing but for the entire volume (feature that i need), also is a Linux system in which special chars are far more normal then on systems like windows, even if a @ is preferably not welcome around… could be enough to instruct SONOS system do ignore a folder name starting with such char… force SMB v1 is not an option  due to security reasons.

by now i will use a subfolder for my library, but i hope this issue will be managed some way.

thanks for the answers ^^