Audible UK problem

  • 20 September 2022
  • 4 replies

Userlevel 1
Badge +1

I listened to Audible books for many years on my Sonos system. That was I now use I find and begin the books easily. My problem is that the system doesn’t save my place. At first, I noticed it would go back to an earlier chapter. Now, it doesn’t even do that. Every time I come back to a book I have to start from the beginning and jump from chapter to chapter until I get to where I left off. All this assumes I neatly finish listening at the end of a chapter. Otherwise, it is chaos.

I spoke to help. Of course, they said it was nothing to do with their books. I needed to speak to Sonos. I told them that I had no problem listening to books from They were not impressed.

I don’t see anyone else with this exact problem. Anyone have any idea what might be happening? I tried to reinstall Sonos. No difference. I’m using S2.


Best answer by Didymus 23 September 2022, 17:17

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

4 replies

Userlevel 6
Badge +14

Just tried starting and restarting - with intervening music station between sessions. 

No problem picking up the dialogue. 

Userlevel 7
Badge +18

Hi @Didymus

Thanks for your post!

I recommend the following steps:

  1. Remove Audible from your Sonos system (see How to remove a music service account from Sonos)
  2. Open the Audible app, and sign out
  3. Sign back into the Audible app, ensuring to use the account
  4. Add the Audible service to your Sonos system once more

If this doesn’t help, you may need to try again from the start, but sign out of all apps on your device owned and run by Amazon - music, Prime, shopping and any others - at step 2. Please also sign out of the and websites on your browser. When signing back into them, ensure it’s the account again.

These instructions are adapted from Alexa troubleshooting steps, so may not work, but given that I’ve never come across this issue before they’re all I can think of. The Sonos app can ask these apps for your login details when you’re adding an Amazon service, so my thought is that it might be pulling the wrong credentials. This would also explain why you still had issues after reinstalling Sonos - though I’m not entirely sure exactly what you meant by that.

It may also be worth simply rebooting your Sonos speakers, if you haven’t tried that already.

I hope this helps.

Userlevel 1
Badge +1

Corry P - That was the first thing I tried. 

I noticed an update was available for Sonos2. I updated and the problem went away. Since I already tried reinstalling Sonos earlier, I’m at a loss as to why the update would make a difference. Who knows? Maybe there was something in the update that made a difference. Or, maybe the Techno Gods were smiling on me.

We can close this thread. At least for the moment.

Userlevel 7
Badge +18

Hi @Didymus 

Another example of why updates are important! Perhaps there was an update to a system library that the server expects a minimum version of - these are the kind of things that discovered vulnerabilities result in and administrators are quick to seal up. This is all supposition on my part - I don’t know any details.

Anyway, I’m glad you’ve got rid of the issue and are able to enjoy your audio books again. Thanks for updating the thread!