Apple Music starts and stops inside Sonos


I just upgraded from my old Sonos 1. Generation (from maybe 15 years ago?) and bought a couple of Move 2’s and a Move.  Installed the new version of Sonos and everything works EXCEPT when I try to play from Apple Music.  I have authorized Apple Music to play in Sonos.  I see the music I want to play on AM.  I select a song.  It either scrolls step by step through the entire album, playing nothing OR if I select a particular song, it seems to play for about one second and then it stops and the play button shows again.  I used Sonos with Apple Music in the past with my old system, never had this problem.  I tried removing and re-adding AM as a service, still the same useless behavior.  I have no idea how to fix this.  Spotify and Sonos Radio working fine.


20 replies

Userlevel 6
Badge +11

I just upgraded from my old Sonos 1. Generation (from maybe 15 years ago?) and bought a couple of Move 2’s and a Move.  Installed the new version of Sonos and everything works EXCEPT when I try to play from Apple Music.  I have authorized Apple Music to play in Sonos.  I see the music I want to play on AM.  I select a song.  It either scrolls step by step through the entire album, playing nothing OR if I select a particular song, it seems to play for about one second and then it stops and the play button shows again.  I used Sonos with Apple Music in the past with my old system, never had this problem.  I tried removing and re-adding AM as a service, still the same useless behavior.  I have no idea how to fix this.  Spotify and Sonos Radio working fine.

Apple Music tracks are now Lossless on Sonos, as of a couple of weeks ago, whereas Spotify and Sonos Radio are not. Your new Sonos Move speakers are Lossless capable and so will be seeking to play in Lossless (higher resolution). Your previous speaker(s) may have not sought out the Lossless versions like your Moves do.
 

So it could be that your wifi cannot process the data quick enough to play these Apple Music tracks? How fast is the WiFi network your Sonos speakers are connected to…?

The  network Sonos is connected to is running at 2.4 GHZ I am not sure what else to say.

Userlevel 6
Badge +11

Thanks. It will all come down to your WiFi download speed. Best way to test is to Google ‘wifi speed test’ and run a test to see what speed you are getting. I don’t know what Sonos needs to play Lossless tracks reliably, but I’d recommend your WiFi speed shows a higher download speed than 10mbps. 
 

 

I have the exact same issue using the Sonos Connect.  WiFi is very fast, could it be the Sonos Connect is not processing the Lossless properly?

I have the exact same issue using the Sonos Connect.  WiFi is very fast, could it be the Sonos Connect is not processing the Lossless properly?

What is Sonos Connect?

 

The  network Sonos is connected to is running at 2.4 GHZ I am not sure what else to say.

It’s more than enough bandwidth to stream lossless. 
Im having some hiccups with the new lossless (skips and drop outs) myself. No issues with other services.  That your other services work to me shows it’s probably an issue with Sonos or Apple. 

UPDATE: I just installed the Sonos controller (current version) on my MacBook - and Spotify etc work - BUT when I try to play something from Apple Music I now have more information: “unable to play XYZ - the connection to Apple Music was lost.”

Wonder what on earth that could mean?

 

 

Userlevel 4
Badge +1

I run Apple Music to stream albums, tracks etc. with this update AM will only play about two tracks and then it stops. It can’t be stopped and started again. If I return to Sonos radio I can start streaming radio continuously but it drops three out of four speakers although the app says they’re still connected.

Yesterday I had a page come up saying I needed to add my devices from scratch although they were still playing in the background.

I have very fast fibre wireless capable of streaming live sport and 4k video so good enough to stream music seamlessly.

This has to be the worst “upgrade” I’ve ever experienced bar none and Sonos should be ashamed at unleashing this to their customers. I’m sure each and every one of us has spent hours trying to get our systems back to how they were prior to this update……with very limited success in my case.

Meantime they bombard me with emails trying to sell me kit that I’ve always been wanting ffs! All I want is my music back again!

Are they taking note?

I run Apple Music to stream albums, tracks etc. with this update AM will only play about two tracks and then it stops. It can’t be stopped and started again. If I return to Sonos radio I can start streaming radio continuously but it drops three out of four speakers although the app says they’re still connected.

Yesterday I had a page come up saying I needed to add my devices from scratch although they were still playing in the background.

I have to very fast fibre wireless capable of streaming live sport and 4k video so good enough to stream music 

Yeah this is pretty similar to my experience as well. Getting random drop outs skips and stops playing. Prior to the lossless update/recent firmware update it worked reliably. Some have commented that it could be my network and fair enough, but I’ve rebooted everything a few times (already have assigned ips to the devices) and still get the issues. 

Userlevel 4
Badge +1

I run Apple Music to stream albums, tracks etc. with this update AM will only play about two tracks and then it stops. It can’t be stopped and started again. If I return to Sonos radio I can start streaming radio continuously but it drops three out of four speakers although the app says they’re still connected.

Yesterday I had a page come up saying I needed to add my devices from scratch although they were still playing in the background.

I have to very fast fibre wireless capable of streaming live sport and 4k video so good enough to stream music 

Yeah this is pretty similar to my experience as well. Getting random drop outs skips and stops playing. Prior to the lossless update/recent firmware update it worked reliably. Some have commented that it could be my network and fair enough, but I’ve rebooted everything a few times (already have assigned ips to the devices) and still get the issues. 

I don’t think it’s my internet causing the issues as it’s always worked until the app update

 

 

Userlevel 4
Badge +1

I assume this is good enough to stream Apple Music through Sonos?

Userlevel 6
Badge +11

I assume this is good enough to stream Apple Music through Sonos?


PLENTY!!!!! 10-20 times faster than you need!

Userlevel 4
Badge +1

I assume this is good enough to stream Apple Music through Sonos?


PLENTY!!!!! 10-20 times faster than you need!

Any idea why Apple Music craps out after two tracks and Amazon music plays seamlessly?

Userlevel 3
Badge

Same issue with a 300 mbps + wired connection, only with Apple Music 🥲

Userlevel 4
Badge +1

I’m still unable to stream Apple Music through Sonos successfully. After a short while the app freezes and the only way out is to reset the router. I can Bluetooth to one of the moves in my system and stream AM to that via my iPhone without issue but I no longer then have the rest of my zones because you can only Bluetooth to one device.

 This issue never happened before the new app and the recent upgrades haven’t fixed it.

 The only thing my expensive system is good for now is streaming radio stations. No private NAS based music library, no streaming, only radio. I’ve spent hours trying to get this pile of junk working to no avail.

Anyone out there know what I’m doing wrong or is it simply that Sonos aren’t supporting Apple Music streaming any longer? HELP!

i have 11 Sonos speakers set up in 5 different rooms that has been working with Apple Music for a long time.  I just added a Move 2, I get the unable to play lost connection to Apple Music message but only when trying to play through the Move 2, AM works with all the older speakers.  I’ve restarted all my phone, router and speaker still the same.  I can play Sonos Radio or Pandora on Move 2 just no AM

Userlevel 4
Badge +1

Same issue with a 300 mbps + wired connection, only with Apple Music 🥲

Have you found a way to resolve your AM streaming issue? I’m still unable to stream Apple stuff

Userlevel 4
Badge +1

I run Apple Music to stream albums, tracks etc. with this update AM will only play about two tracks and then it stops. It can’t be stopped and started again. If I return to Sonos radio I can start streaming radio continuously but it drops three out of four speakers although the app says they’re still connected.

Yesterday I had a page come up saying I needed to add my devices from scratch although they were still playing in the background.

I have to very fast fibre wireless capable of streaming live sport and 4k video so good enough to stream music 

Yeah this is pretty similar to my experience as well. Getting random drop outs skips and stops playing. Prior to the lossless update/recent firmware update it worked reliably. Some have commented that it could be my network and fair enough, but I’ve rebooted everything a few times (already have assigned ips to the devices) and still get the issues. 

Have you managed to resolve your streaming issues yet? I’m struggling with Apple streaming still

Userlevel 4
Badge +1

I just upgraded from my old Sonos 1. Generation (from maybe 15 years ago?) and bought a couple of Move 2’s and a Move.  Installed the new version of Sonos and everything works EXCEPT when I try to play from Apple Music.  I have authorized Apple Music to play in Sonos.  I see the music I want to play on AM.  I select a song.  It either scrolls step by step through the entire album, playing nothing OR if I select a particular song, it seems to play for about one second and then it stops and the play button shows again.  I used Sonos with Apple Music in the past with my old system, never had this problem.  I tried removing and re-adding AM as a service, still the same useless behavior.  I have no idea how to fix this.  Spotify and Sonos Radio working fine.

Have you managed to resolve this yet? I’m still struggling to stream Apple Music reliably

Userlevel 3
Badge

Yes, I just group the speakers with an older play 1 so that lossless won’t turn on and it works fairly well.

Reply