Answered

Apple Music - can't connect

  • 3 October 2020
  • 26 replies
  • 8495 views

Hi there, for the past couple of weeks I’ve been unable to connect to Apple Music. “We’ve run into a problem. Please try again.”

 

Tried signing out of Apple Music, reinstalling sonos app etc. No luck.

 

icon

Best answer by Annazel S 8 October 2020, 21:04

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

26 replies

Userlevel 7
Badge +18

Hi @steviek 

Thanks for posting that - it’s a good round-up of what often needs to be done. A few points:

  • We prefer 802.11 b/g mode as n mode involves band steering which doesn’t work well with Sonos as our older products (and soundbars) reserve their 5GHz radio for bonding other speakers. However, your system uses SonosNet because the Beam is wired to ethernet (or at least it was when the diagnostic was submitted) so your WiFi settings are irrelevant to Sonos, unless the channel it is on overlaps with the channel SonosNet is on (only channels 1, 6 and 11 do not overlap).
  • Client isolation is what you’d want in a public network - devices are not allowed to communicate to each other, only the internet. Sonos needs this option to be disabled to maintain the system.

Looking at the diagnostics, however, I can see that the Beam is having a hard time communicating with the rest of the system (and the rest of the system utterly relies on this connection). What is within 1m of your Beam, apart from your TV? Is it surrounded in anything massive, like lots of books, thick wood or large plant pots? If so, please try to remove them slightly.

Also, your WiFi network is split between channels 1, 4, 7 and 9 - are you able to get all these on one channel? Ideally 1 or 6 as Sonos is using 11. Overlapping channels are actually worse than using the same channel, as when the same channel is used, transmitters will time-share to avoid issues. On slightly different channels that do overlap this is not done and interference can be a result.

Are you able to wire any other Sonos speakers (in rooms other than the Beam) to ethernet in addition to or instead of the Beam? You either need a better location (I mean a different speaker, not moving your Beam!) for your wired unit, or have more than one unit wired.

I also noticed you have quite a large group set up. Have you tried changing the room that is the master (Group Coordinator) of that group? If not, please disband the group, select another room (Sitting Room B looks best, currently), then regroup the wanted rooms back in and test. Ideally, you want your wired speaker in charge of a group but as your TV Room wasn’t included, this isn’t an option. The next best choice is the speaker that has the best connection back to the wired device.

I did see evidence of multicast flooding (which IGMP Snooping filters out) - please switch your main router off for at least 30 seconds and switch back on as this may fix the flooding. You can purchase a managed switch that would provide IGMP Snooping on ethernet for less money than a restaurant dinner for two - just search Amazon for “managed switch” in the Computers & Accessories section. Make sure that IGMP is mentioned in the specifications (Snooping, Storm, Filtering - anything like that). The switch would connect in between the router and your wired Sonos device(s). I recommend this only as last resort - I would be surprised if you could not get things working satisfactorily without spending more than the cost of an ethernet cable.