Android Sonos wont load past term condition

  • 18 June 2024
  • 9 replies

Android Sonos wont load past term condition there is no option to move on. I was forced for the update and everything stopped working. Like most rubbish apps a reinstall fixes this. No this made it worse  I now have no options but to select which country terms and conditions and that is it will not proceed from there. I now have a phone that i cannot operate any of my sonos devices


Best answer by Corry P 5 July 2024, 13:05

View original

9 replies

You need to scroll down to the bottom of the terms before the accept button will then allow you to click it. 

it does not scroll

Userlevel 7
Badge +18

Hi @michaelw3 

Welcome to the Sonos Community!

I’m sorry to hear of the issue you’re having with using the Sonos app on your phone!

Could you please let me know the details of your phone? Make, model, Android OS version, etc. Thanks.

If you can screen record the situation and upload it to a file sharing site or to YouTube (be sure to make it public), leaving a link to it here, that would be extra useful! 

my phone is a Samsung galaxy s24+


Userlevel 7
Badge +18

Hi @michaelw3 

Thank you for those details. Just to be sure, have you tried scrolling down by touching the screen at different points?

Also, I’m a little confused by the following: “I now have no options but to select which country terms and conditions”. Are you being asked which country you are in? Can you please provide a screenshot?

As nothing else is working, please try the following:

  1. Uninstall the Sonos app
  2. Restart your Samsung phone
  3. Reinstall the Sonos app
  4. Try again

I hope this helps.

I have tried all the suggestions still not working. There should be an option to install a  previous version as the current version has caused loads issues for people 

Userlevel 7
Badge +18

Hi @michaelw3 

I can now only recommend you get in touch with our technical support team who have tools at their disposal that will allow them to give you advice specific to your Sonos system and what it reports.

Sorry I couldn’t be of more help.

Userlevel 7
Badge +18

Hi @michaelw3 

We have now identified an issue whereby some users will be unable to progress past the step of accepting the Terms & Conditions within the Sonos app.

Please ensure that you have not set your mobile device to enlarge the contents of the screen in any way - if you have, setting the zoom back to the standard setting may allow you to accept the T&Cs in the app.

If the above does not help, please try using the Sonos app on a different device in the meantime - if that is an option for you.

We have no estimate for when a fix might be put in place, but this issue is a high priority. I’ll update this thread when it is resolved. Thank you for your patience.

I hope this helps.

There was no zoom or enlarge setting.  I had to factory reset my phone to get the app working again. Still have issues with the app having to reconnect to my system each time I use it.  The app has been absolutely awful since the forced update as can be seen by the amount of complaints in the reviews 🤬