Answered

Amazon Music in Canada

  • 25 March 2023
  • 2 replies
  • 83 views

Badge

I haven’t been able to connect my Amazon Music Unlimited to the Sonos App

Won’t let me browse.  I believe its because when I add it on the app, it defaults to the US Amazon (.com) and not Amazon Canada (.ca) which is who I pay for Amazon music

 

Is there a way to fix this so I can browse and play music through the Sonos app?

icon

Best answer by GuitarSuperstar 25 March 2023, 18:58

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

2 replies

Userlevel 7

Log in to the main Sonos website and go to your account profile and make sure your country is set to Canada. You may also need to remove and re-add Amazon Music in the Sonos app.

Same issue: trying to add Amazon music Canada but Sonos sends me to Amazon.com not Amazon.ca. 
But I cannot see anywhere in my profile a country setting to change to Canada from US. 
I tried changing the data and time to Saskatchewan but that didn’t work. 
Any help on either changing country from US to Canada or another way to access Amazon.ca would be appreciated. 
Thanks