Answered

Amazon Music app not passing metadata to Sonos?

  • 21 May 2023
  • 2 replies
  • 1008 views

Userlevel 2

I swear this worked for a few days as I tried out the Amazon Music Unlimited free trial, but now the iOS Amazon Music app does not seem to be passing along metadata (artist, song, album art) to the Sonos app. Instead, I just get a grey screen on Sonos with “Started from Amazon Alexa” at the bottom.

 

I did briefly install Alexa on one of my Sonos One’s (and then uninstalled) about the time this started. Anyone have ideas, or seeing the same thing? I’ve removed & re-added speakers to Alexa, disabled and re-enabled the Sonos skill in Alexa….still cannot get the AM app to work properly.

 

Metadata is passed properly with AirPlay casting, and everything is great when started within the Sonos app. Is anyone else having problems with the AM app casting to Sonos speakers?

icon

Best answer by Jamie A 22 May 2023, 15:48

View original

2 replies

Userlevel 7
Badge +15

Hi @jdd21218,

I’ve just had a colleague test and they were able to have the Now Playing screen show what’s playing instead of just “Started from Amazon Alexa”

Generally removing and re-adding the skill would fix small issues like this, however as you noticed this issue after testing the Amazon Music Unlimited free trial, I would suggest re-authorizing the Amazon Music service in the Sonos app. You can do this by going to Settings → Services & Voice → Amazon Music → Reauthorize Account. After doing that, try initiate playback with Alexa to see if the app is now correctly displaying what is playing.

If that doesn’t resolve the issue, then it would be best to fully remove then re-add Alexa. You can do this by following these steps:

  1. Remove Alexa from the speakers in the Sonos app.
  2. Remove all Sonos devices from the Alexa app.
  3. Sign out of all Amazon apps on the controller (such as Prime video, Amazon Music, Amazon Photos, Kindle, etc).
  4. Follow the set up process in the Sonos app for Alexa.

Again, try testing playback after doing the above to see if the now playing screen is showing correctly.

If none of these steps resolve the issue for you, I’d recommend reaching out to our support team for further troubleshooting assistance.

I hope this helps!

Userlevel 2

Thanks for the suggestions, Jamie - I’ve tried everything, but with very intermittent success. I’ve found that if I connect to a Sonos device while a song has already started on the AM app, no information is passed. If I then press “next track” on the AM app, the music changes and song information is communicated to the Sonos app and shows properly.

 

But this only happens once - after that, when the song completes and the next track begins, I’m back to gray square and “Started from Alexa”. The only way to get it to work again is to disconnect from Sonos device (stop casting), reconnect, play a track...and once again press “next track”.

 

If this continues, I’ll definitely find time to step through this with the technical support team.

Reply