All speakers disappeared from Sonos app and will not reinstall

  • 13 March 2023
  • 8 replies


I have had a Sonos system with 4 speakers for a few years and it has been working great until recently.

I noticed that a couple of the speakers disappeared from the Sonos app (S2?) so I tried all sorts of options and eventually got them to reappear. Then one speaker was unplugged and moved to a different location and it was then lost in the Sonos app!

Then, we had a power cut and all speakers disappeared again.

I have been trying to get them all back but they just won’t connect anymore!?

I have 2 x Play:3, 1 x Play:1 and 1 x One (Gen 1).

The wifi is provided by a Netgear Orbi mesh.

Internet is via a Technicolor DGA0122

The Sonos app is the latest version (v15.1.1)


I have restarted the router, the Orbi wifi and every single speaker. I have reset each one (by holding the necessary buttons until the speaker chirps and flashes amber). They usually connect to the SONOS wifi but not always, they then fail to connect to the Orbi wifi. And yes, the password I am entering is correct!


Any ideas on anything else I can try before I put them all on eBay?


Best answer by GordsM8 14 March 2023, 09:14

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

8 replies

First off, refrain from further “resets”, which we usually call a  factory reset . More often than not (approaching 100% of the time) it only obfuscates rather than fixing any issues, and has the side issue of erasing all data from the speakers that Sonos could use to help you.

Sonos tends not to like mesh networks, including Orbi’s for lots of reasons. I’d suggest that you connect one of the devices to the root of your Orbi mesh with an ethernet cable. That device should be the router. Doing so should allow you to add it in your Sonos controller, then it should be fairly simple to add the rest of them to your system, using the “add a device” function in the Sonos controller.

If you are unable to maintain a device wired permanently to your Orbi router, I’d recommend a Sonos BOOST. It functions in the same way as connecting a speaker, without the extra “speaker” part, by creating the SonosNet network for all your speakers to connect to.

I suspect that one reason this stopped working as it had before is that Netgear sent your Orbi system some sort of update that “broke” the connection you’d been using to the Sonos. Not sure, I’ve managed to never install the Orbi system that I was given, but until recently, was a devotee of the BOOST myself. When I move soon, hopefully I’ll use my BOOST again, as the new accommodations don’t currently suggest an easily wired speaker (although that may change, who knows...but holding on to my BOOST).

There’s more information you may want to peruse on the wireless and wired systems FAQ.

Userlevel 7
Badge +18

Since you have factory reset them, you’ve deleted any diagnostics data that Sonos support could have examined. Try connecting one of your speakers to the main Orbi hub with an Ethernet cable and going through the setup process again. 

Edited to add: Bruce gives a lot more info, and did it first! 


Since you have factory reset them

Well, that is what the Sonos App told me to do!

Do I need to specifically connect one of the speakers to the Orbi, or can I connect it to the network / router (as that is easier to do)?

The device you want to (the system wants you to) connect to is the device generating the IP addresses. Normally speaking, that’s the base router part of the Orbi, but it’s unclear what this additional “network / router’ part is. 


The device you want to (the system wants you to) connect to is the device generating the IP addresses. Normally speaking, that’s the base router part of the Orbi, but it’s unclear what this additional “network / router’ part is. 

The Orbi system is used just for the Wifi, the Modem / router is the Technicolor DGA0122 which has it’s WiFi feature disabled. It is in a location that would not enable it to send WiFi around the entire property, plus there are other issues.

I did have one speaker wired to the network - but had disconnected that cable (forgot that it was required). I will reconnect and try again.

Userlevel 7


You’ve gotten some great advice here; therefore I really have nothing to add by way of resolving your issue. I will offer this...regardless of what brand of mesh network you use they can be problematic for Sonos. 

Mesh networks typically have 3 bands. They are 2.4Ghz x 1 and 5Ghz x 2. One of the 5Ghz bands is used to connect the main router to the nodes. That is called a Wireless Backhaul. The backhaul band has limited connection available for devices; but some will still try to connect to it. Sonos devices connecting to it will sometimes disappear. 

I’m confused about your statement “Internet is via a Technicolor DGA0122”. I assume the device is provide by your ISP. That said the ”Technicolor DGA012” (if a router/modem) should be placed in Bridge Mode. Your Orbi’s main node (router) should be connected to it via ethernet cable to send the WiFi signal. If possible you might try isolating each band with a unique SSID.

I have an Asus ZenPro ET12 Mesh with two nodes. However, they are connected via ethernet for a Wired Backhaul. The advantage being that each node broadcasts a clean Wifi signal via all bands. However, my Sonos uses the SonosNet provided by a Sonos Boost.

FYI, my ISP is Xfinity and I have their supplied router/modem in Bridge Mode with my main Asus Zen Pro ET12 connected to it via ethernet.  However, my Sonos uses the SonosNet provided by a Sonos Boost. 

Mesh does not need to be problematic. I have an Xfinity Gateway and a PLUME mesh. I have two different SSID’s for the Gateway and a single SSID for PLUME. SONOS is using PLUME and phone/pad can use any of the three SSID’s on a whim. ROAM and MOVE are WiFi, of course, the other units are usually SonosNet.


Thanks to all that replied, very much appreciated.

 I’m found the problem, late last night - the Orbi WiFi was not configured in AP (Access Point) mode.

A little while ago something happened to the Orbi which made it completely reset (a bad upgrade maybe?) and I had to reconfigure it, but must have forgot to set it to AP mode.

As soon as I did that, all of my speakers reappeared!

It’s a shame that not being in AP mode didn’t cause more issues as I maybe would have figured out the issue sooner - oh well.