Answered

A skipping issue so specific, there has to be a solution...

  • 11 July 2023
  • 6 replies
  • 233 views

Userlevel 2
Badge +4

Yeah this skipping issue is so finite that it is reproduced like a charm and throws everything to crap.

 

Context: We have a yoga studio and on the studio side we have 6 Play 3’s and Sub Gen 3 and a Boost, in the lobby we have 2 Symfonisk bookshelf speakers. All teachers in the studio use Spotify. The Boost is hardwired to the router and everything else is wireless. The router is a Netgear Nighthawk running speeds I can never fathom to use and wireless connection throughout the studio is insane. I placed the Boost 6ft away from the router and both 6ft away from the Xfinity Modem. We removed our Sonos Connect, plus a Battery backup unit, all to reduce interference. We have over 16 people connected to our Sonos system, something that Sonos wasn’t prepared for apparently, most use cases never exceed 10 users, but we did. However only 1 person is connected at a time, that is it. In addition to the Teacher playing from their phone as a controller, we have an iPad that has Sonos and is connected in case a teacher forgets. We went through the “Spotify Crossfade” issue where disabling “Crossfade” solves that skipping issue, and it did. This issue presented before the crossfade one and pops up every so often: 

The Issue: Play a playlist, first 2 play great, the 3rd song skips, then it takes just under 30 seconds to start playing track 4. Like clockwork this issue is so consistent and very specific save for the fact I have no clue what is causing it. No change in network, no change is speakers, nothing. This doesn't happen on any other service than spotify. Apple music or Sonos radio do not present these issues.

My Thoughts: All roads point to Spotify music service on Sonos is the issue. Furthermore when we had the whole “Crossfade skipping” issue I figured out a solution, which was to play audio through the Spotify app directly, then when it starts playing tap the speaker icon and select Sonos speakers as my source. It plays perfectly without skipping however the issue here is that volume control for Sonos via Spotify is truly dumpster fire. 

 

This skipping is very specific, maybe someone else has had it and found a different solution much like the Spotify workaround for Crossfade. 

 

Any thoughts?

Diagnostic # 1943234122

icon

Best answer by GLO Yoga 13 July 2023, 21:50

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

6 replies

Userlevel 2
Badge +4

I reached out to Sonos and they are always amazing to help but unfortunately for this issue all roads point to interference each time and the hard part to understand is that if nothing changes in regards to interference meaning no hardware or physical objects how does that all of a sudden become a factor.

 

My thoughts is Sonos cannot handle more than 15 controllers of the same audio service on one system, maybe that IS the interference? Come to think of it, this issue amplified when we got to 17.

Sonos can always be affected by outside sources. Every electrical system can, and moreso any wifi based system. 

The Sonos system is designed to accept up to 32 controllers. 

Userlevel 2
Badge +4

Thanks @Airgetlam Maybe adding another Boost can help strengthen the signal between speakers, shoot at this point it’s worth a shot…

 

Userlevel 2
Badge +4

Solution: For me I was able to resolve this, not sure for how long but here is what I did. I unplugged all Sonos devices. Opened up the app, it asked said there was an issue and to tap to “fix it” I did not choose that option. Instead, I plugged in the Boost and held the power button until it flashed green, I let it be the first device added to the system. Interestingly it created a room called “Boost” (I have not seen the same when adding a Play 3). I then added every speaker the same way one by one and added them all to the “Boost” room that was created. Finally, I clicked the device tab and grouped them all and hit play. 

 

So far, we have run 120 mins with no problems that we were experiencing earlier. I will follow up if things do not hold. I hope this can be helpful to anyone else. 

 

Best 

Userlevel 2
Badge +1

I have this issue. I unplugged all my non ethernet connected speakers. I only had my wired ethernet cable connection between Arc and router. One speaker. Wired into router. Still the Spotify skipping issue and silence while playing a song issue occurred. Another streaming source like Mixcloud provided no issues. Spotify plays via phone without this problem.

This is definitely a Spotify via Sonos issue. Surely they know what is happening here

Userlevel 2
Badge +1

I wonder. I always select random play on my Spotify via sonos.. i wonder if it would happen with shuffle off 🤔 if crossfade was an issue... Maybe