2024 iPhone S1 app not seeing my Sonos devices

  • 2 April 2024
  • 9 replies

Late in March 2024, my iPhone S1 app stopped seeing my Sonos devices.  I found earlier fixes that don’t help.  I have an iPhone 11 Pro Max with iOS 17.4

Settings->Privacy & Security->Local Network->Sonos S1    is ON and was always ON

Settings->Sonos S1->Local Network    is ON and was always ON

I toggled the settings, rebooted my iPhone, and deleted and reinstalled the Sonos S1 app, to no avail.

The same settings and symptoms are true on my wife’s iPhone X.  Sonos S1 used to work, now cannot find any devices.

I know it’s the controller because the whole system is seen and works from the Sonos S1 PC app and by Python sonos macros on my Linux PC and my wife’s Windows PC, but it’s cumbersome to not be able to control from my phone.


Best answer by controlav 3 April 2024, 14:40

View original

9 replies

Ooops.  The topic is from 2024, not 20,224!  Sorry

Please describe your network. Any chance you’re running a mesh network? Or is your system connected via SonosNet?

All my devices are on the same subnet.  I have a cable modem on my public IP.  That connects only to my single router which only creates one subnet.  I have a WiFi AP that acts as a bridge, so everything on WiFi is on that same subnet.  One of my Sonos devices, a Play-1, has ethernet through several layer 2 switches to the router.  The other Sonos devices talk to each other over WiFi, I guess that’s SonosNet?

Thanks for your quick reply!

Yes, if a single Sonos device is wired by Ethernet, then the rest of the older devices will be connected by SonosNet, but any newer devices (Roam, Move, Era speakers) will be connected to your WiFi signal. Ah, rereading your first post, you’re using S1, so none of the newer speakers, we will assume that they’re all on SonosNet.

What happens when you temporarily turn off that Access Point? 

Also, what happens when you connect that PLAY:1 directly to the router, rather than through these multiple Level 2 switches?

Which router and Access Point are you using?

Userlevel 7
Badge +23

You’ve checked the Local Network option, which is good as it is the most common issue on iOS.

Also check the Private Address option for your WiFi - disable that as some routers are not compatible.

Final option is to ensure you do not have a VPN installed (eg via MDM from your employer).

Are your PCs that work wired, or wireless? And yes, please, tell us about your local network.

If none of those work, try my app “Phonos Plus” from the Store and see if it can find them. If not I can take a look at the diagnostics and see if something can be determined there.

You can go to http://[address of a player] :1400/support/review and display the Network Matrix. Red cells indicate wireless communication struggles.

I am on vacation for a week (eclipse tourism!) and I will try all your suggestions when I return home.  Thank you for your suggestions.

The problem was my VPN on the phone.  I didn’t change any settings and it used to work.  I fixed it by turning on:

ExpressVPN/Settings/Network Protection/Allow access to devices on local network


I don’t know why this worked for years but failed in late March.  Thanks for all your help.

Glad you figured out how to fix it. My experience with things like that is there is some background update that happens without your knowledge that updates your settings…