Windows media streaming - browse by folder - how to play more than one track

  • 7 January 2021
  • 5 replies

We play music and kids’ stories served from a windows server. This worked fine for years. After disabling SMB1 because it was 2020 and failing to get the http service to work (with or without firewall) I set up windows media streaming over what looks like RTSP.

We use the Sonos Android app (12.2.2), and also the Windows one, less often. Navigating the metadata works as expected, but this is not generally how we use the app. It isn’t really feasible to browse, or even search, tens of thousands of objects, made up of four or five distinct collections, as a flat list. The way to do that is to use folders. But navigating by folder does not work as expected: the app browses and finds the content, but it does not treat the folder as a potential playlist. In contrast with other sources (I’m thinking SMB folders, Spotify, Amazon) it does not associate play/add functionality with the list it has found. There aren’t any buttons. Click on a track and it dutifully plays that track and then stops. It lists all tracks, so it recognizes them as an array, but it will not transfer that array to a playlist.

The ask: how do I play RTSP folders?


Best answer by controlav 8 January 2021, 15:43

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

5 replies

Userlevel 7
Badge +22

Sonos has zero support for RTSP sources that I am aware of. It has iffy DLNA support: its not standards-compliant, but it allegedly works with some UPnP sources.

How exactly did you enable “Windows Media Streaming”? Which OS is running on your server?

I have Windows Server 2012 Essentials and I use the http library service on there to share its content, without issue. That is the recommended solution to sharing files from Windows devices.

Thanks! I followed these instructions on to enable media streaming via Media Player. Prior to that, I didn’t even know Media Player was still a thing. It says it’s using RTSP with UDP, but I’m willing to believe it is also doing something different in the background. This is Windows 10 Pro.

http sounds more elegant but it hasn’t worked so far. The Sonos service is there, but at setup & share time, after selecting a folder and butchering the firewall, the Windows app claims not to be able to find the server, i.e. the machine it is running on and from which I have just selected the folder. Forcing the service to run first doesn’t work either. Nor does turning the firewall off. Nor does reinstalling everything. I haven’t found anyone with this issue on the forums.

Is the local network interface set to ‘Private’?


Userlevel 7
Badge +22

I had no idea about this option, need to dig further and see how it works.