S2 Android Music On Device Not Working.

  • Contributor I
  • 2 replies

After updating from S1 to S2, the music stored on my samsung galaxy A40 can no longer be played from the S2 app. The error I’m getting is [x-track] is no longer available on [my phone]. All music can be played on other apps (and is stored in the Music folder). I’ve granted all permissions (going so far as to uninstall the app, forget my home network, reboot and reinstall everything.) Am not sure what’s wrong. 


Best answer by beagle123 7 October 2020, 12:19

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

14 replies

My S9 still seems fine so it isn’t totally generic.  I know you mention permissions, but can you confirm that in your Phone’s settings, under Apps, Sonos is granted Storage permission?

Which Android version  is your phone on?

The android version is 10 and storage is allowed


I am afraid I don’t have anything else to suggest.  I don’t think Sonos have ever been very keen on playing from a mobile device - it wasn’t part of the original design and doesn’t seem to get any attention.   For playing local music I have found a NAS to be better in many respects, although I am not saying that is best for everyone.

You might try submitting a diagnostic (Settings, Support) and posting the number back here.  Run the diagnostic immediately after a failed attempt to play from your phone.

Diagnostic number: 1360175885

Thank you for your help John. On the part of Sonos the company (and not on that of you personally), that is a very weak excuse and will be making me reevaluate my continued use of the product. S1 worked great, hence my disappointment.

For the avoidance of doubt I am a fellow user expressing an opinion and my perception.  I am not connected to Sonos in any way.

As I stated, ‘on this mobile device’ works fine for me on S2 as it did on S1 (although playlists only work if I use Samsung Music to create them, which is not what I would expect).


I'm a Beam user in Japan.
The exact same thing is happening on the Samsung Galaxy S9.
I can't play local music. Music service playback is working properly.

Exactly the same issue on my Samsung S20. The player for streaming music from the device via the Sonos app was horrible to begin with, and now it doesn't work at all.

Exactly the same is happening for with Android 10 on my Galaxy S20. My wifes phone with Android 10 works perfectly fine.

I’ve fixed this by going back to version12.0.6 of the app. You can then upgrade back to the latest app (12.1) and it will continue working.

beagle123 = Genius


beagle123 = Genius

I could play local files.Thanks a lot!

Exact same issue here.

Sonos five just arrived yesterday. Installed with a Samsung Galaxy A40 (Android 10 updated).
My main use will be playing music from my phone (many CDs ripped inside to let me listen to them everywhere).
The error was [x-track] is no longer available on [my phone], exactly the same explained by ATT.
Also it happened with a Xiaomi Redmi 8 (updated as well) of my wife.
After many tests (router reboot, Sonos five reset, app reinstall, etc.) I was almost ready to send back to Amazon my new Sonos device.
Thanks to beagle123 I solved: rollback the app from 12.1 to 12.0.6 (from apk mirror)
Sonos technician should seriously consider to solve the issue of the 12.1 app.

I have similar issue, I downloaded the 12.0.6 from apk mirror. However after installing this version and opening the app it's asking to install 12.1 and again same issue. I'm trying to play songs from my oneplus mobile.

Did that too on my oneplus mobile and it works now. Disabled automatic updates.