PSA: DO NOT UPDATE TO THE NEW APP YET (list of issues included)



Show first post

103 replies

So glad to see this. Just updated the app and I’m so sorry I did.  Nothing works.  It won’t let me change my network.  It isn’t finding my speakers. I’m beyond frustrated.

Badge +2

I'm not going to be surprised if sonos actually does rollback this one.

As the list of issues seems to be growing.

A great idea, but we always say this. It never happens. It never happens because, alas, they simply do not care. That and the small fact the company might as well rename itself Hubris.

None of my speakers can be found on the new app update. I finally got to the “software update” screen and now I’m stuck on an error “log in as system owner”. I am the system owner so I’m not sure what this means. 

I’m exactly the same, please post if any more updates, thanks 

There is so much wrong with this new app it’s hard to know where to start. Such a lack of professional ethos is  doing a great deal of harm. The queue is unmanageable and totally useless. There is no usefull management for the system.I use locally stored files.The details of where and how to manage files,refresh caché add or delete file storage etc is nowhere to be found. The whole look is a copy of all that is out there combined,not very original or intuitive. Please SONOS do something about this or you deserve to go under

Userlevel 2
Badge +1

Rebooted my phone.  Still cannot get true play to work with my arc and era 300. Mike switch is on as recommended. Not sure what else I can do. 

Userlevel 7
Badge +4


 

Because why the hell would even the update of your products themselves worked, when the whole app is f*cked up pretty good, right?

App version 80.00.04. / iOS 17.5

Took approx. 7 Minutes. Update ended with Error: 1 001 fo each of my 8 products.

This is just pure magic u did with the new app.

Pure freakin’ Harry Potter wizard chonga bonga sh*t.

I totally expect at this pace, that the doomsday will come, when one of your updates, is going to brick one or more of my speakers.

And be aware, that when that day comes, expect that the whole European freakin Law Enforcement Frontal Ursula von der Leyen attack will come your way, because this whole new redesign brave new world app sh*t u did, is getting on my nerves real fast.

have just registered here after 15 years of Sonos use to register my horror at the latest update. Hopefully Sonos are counting these messages and are about to offer a revert feature

80.00.08:

Arc, 2 gen3 subs, 2 era 300s. Trueplay gets as far as waving/walking portion then stalls. Uninstall/reinstall of app doesn’t fix it. Also tried the play music trick for 10 seconds and still a nogo.

Userlevel 1
Badge +2

Hi. Issue is new app lacks a play button for artist radio and top tracks within Tidal.  Could be similar omissions in other “bulk operations.”  Currently, user has to click on each song manually after prior song to keep music going.  Thanks. 

Sonos will not reconnect my Era 100s as surrounds after the new app dropped them from my Arc and sub setup. Have factory reset and adding them individually to different rooms to try to add them but to no avail. I have two era 100s sitting in my living room collecting dust!

Userlevel 2
Badge

80.00.08:

Arc, 2 gen3 subs, 2 era 300s. Trueplay gets as far as waving/walking portion then stalls. Uninstall/reinstall of app doesn’t fix it. Also tried the play music trick for 10 seconds and still a nogo.

not working for me too… 

80.00.08:

Arc, 2 gen3 subs, 2 era 300s. Trueplay gets as far as waving/walking portion then stalls. Uninstall/reinstall of app doesn’t fix it. Also tried the play music trick for 10 seconds and still a nogo.

not working for me too… 

80.00.08:

Arc, 2 gen3 subs, 2 era 300s. Trueplay gets as far as waving/walking portion then stalls. Uninstall/reinstall of app doesn’t fix it. Also tried the play music trick for 10 seconds and still a nogo.

not working for me too… 

I stayed on hold with support for 2 hours and they pushed an update through that fixed in 10 minutes smh.good luck

Half baked and half done. This change is IT zeal overriding smart management decisions. We have all spent LOTS of money on their products then they take away basic functionality making us all hostages. What's next, forced playback of Newspeak from the Thought Police?

Favourites are all gone in a new App on iPhone. Still there in Mac version of app. 

it says - “Unable to load content”, playlists, radio stations, nothing…

No new item can be added either. 

 

This app is seriously broken. It must be removed from the App Store !

Userlevel 2
Badge +1

Tech support was able to help me true play the 300 when separated.  As far as The Arc system they are having issues with IOS and are currently working on fixing to work with the arc. 

Userlevel 1

Please if u have some issues u don’t see in my post, add them with bulletins, so there is a comperehensive lists for other users or the SONOS itself.

 

Device: iPhone 14 Pro Max - iOS 17.4.1

1.) If u’re trying to TruePlay ERA’s 300 in the NEW APP (80.00.04), and microphones are disabled on the ERA’s themselves, then the TruePlay process fails.This is due to disabled microphones. If i tried it in the OLD APP (16.1), there was a step/prompt that warned me exactly about the microphones e.g. that they need to be enabled, so the TruePlay could run successfully. This prompt is missing in the NEW APP (80.00.04). So if u’re having TruePlay issues, try to enable microphones.

2.) If u’re having issues with TruePlay not starting after tapping/hitting “Continue” button in the NEW APP (80.00.04), reboot your phone and it should work.

3.) If u’re experiencing some other issues in the NEW APP (80.00.04), they might be mitigated by going to “Account” / “App Preferences” / “Reset App” which will logout you out of the app and u'll have to sign in again and go through the initial wizard, which's gonna find your existing system.

4.) I also had issues with my existing Apple playlist. After hitting play, songs were skipped one by one and nothing was playing. NEW APP (80.00.04)

5.) The removal of surrounds simply doesn’t work in the NEW APP (80.00.04). Even if i’ve factory reset them, the process failed. When i tried it on the OLD APP (16.1), it worked like magic.

6.) Addition of new speakers (ERA 300 in my case) did not work in NEW APP (80.00.04) either at all, or it crashed during the pairing/registering/wi-fi wizard. I’ve spent approx. hour on Sonos support to achieve nothing.

7.) “System Settings” / “Manage” / “About my system” / “Audio in:” doesn’t display the audio format/kodek in the NEW APP (80.00.04). So for example, if u’re wondering if lossy DD+ ATMOS is playing or the lossless DTHD ATMOS is playing, at the moment u're out of luck. NEW APP (80.00.04)

8.) “System Settings” / “Manage” / “About my system” / “Sonos ID. ”If your ID is not displayed, try the “Reset App” steps and it could help. NEW APP (80.00.04)

9.) “System Settings” / “Your System” / “Room” / “Products” /  “Specific Product” / “Status” / “Network”. The input field is empty and does not display name of the network for existing products. NEW APP (80.00.04)

10.) “System Settings” / “Your System” / “Room” / “Products” /  “Specific Product”. Enable or Disable Wi-Fi does nothing / displays “Something went wrong” error. NEW APP (80.00.04)

  1.  “Music Library” is forgotten and no music folders can be added back.

Adding errors:

This new app in Android don't allow to configure Amazon Alexa assistant with Sonos Era 300, is still loading to login to Amazon Alexa and never go to the login screen. 

This app also forget the configured systems and options of the account. I had to factory reset and configure my two Sonos Era speakers again and the music services. 

The trueplay option for my Sonos Eran 300 and Era 100 don't appear in the app.

The app has too many bugs that difficult to connect to the speakers. 

 

The old app is too much better than this new one. This new app is unusable.

Userlevel 1

I have Arc with Symfonisk bookshelves as surrounds. Since the update, the Symfonisks don’t play anything. I’ve reset them a few times, and after fiddling around managed to add them as surrounds to Arc 3 times now, but there’s no sound coming out of them even though they are shown as surrounds. I also have a Symfonisk in my study which keeps disappearing / reappearing in the app. I don’t think they’re updated or not updated properly, since checking for updates on them keep failing despite having gone the update process when adding them as surrounds. 

 

Also my Arc + Symfonisks don’t show as Airplay speakers on my iPhone except occasionally. 

There’s also a weird bug with the volume control. I change the volume in the Sonos app and the volume slider bounces back to the original position. After trying to change the volume a few times, I saw the volume slider move back & forth independently as with a massive delay. 

The new app is massively glitchy. Speakers come and go, app gets unresponsive, some buttons don’t work until the app is killed & relaunched and everything is super laggy. 

what a disaster of a roll out can add a simple sonos port to an existing system.

I had an issue where my rears (ERA 100s) stopped playing any sound. Had to factory reset and re add which took forever as they wouldn’t register. This only occurred after updating the app.

Now they are working again the trueplay process gets stuck on the final step. 

Userlevel 3

The new app is working ok (still not perfect) on my iPad but not on my pixel 6a android 14. Sometimes it connects but virtually unusable, most of the time it does not connect. Sonos should be ashamed of themselves.

 

 

 

Userlevel 1

The new app is a hot mess. The lag is massive, like it needs to connect to Sonos servers before it can do anything. I can be watching TV plugged into Arc, and when I open the app it shows ‘No songs in queue’ for a minute or so, before realising there’s a live audio stream and then it starts to show TV Audio. 

When I watch YouTube and have a break, when I put on another YouTube video the audio is muted and Arc is not responding. I can see that my AppleTV is receiving the remote signal of increasing volume because the little white led is reacting, but no audio from Arc. It takes 30+ seconds before the audio starts, so now I have to restart the video whereas a few days ago there was no delay. 

Trying to adjust any settings in the app is a nightmare. I adjust any slider and it bounces back. I have to do this several times before it sets to where I wanted to be. Same thing with volume. Trying to add new zones into currently playing zone has the same problem, the app keeps unselecting the new zone. 

Looks like my Symfonisks have now been updated in the background / or their update is not available from Sonos as no updates are available. The Arc’s Symfonisk surrounds are finally working.

My Arc + Symfonisk surrounds are not visible in my iPhone’s Airplay selection, nor is the Symfonisk in my Study or it’s there and disappears. I can see the AppleTV in the living room, but not the Arc + Symfonisks connected to it, so if I want to Airplay from my iPhone I have to turn on my TV. 

There seems to be two major issues. The massive lag in the new app and Symfonisks are not working like my other Sonos speakers (Arc, Roam, Move). 

 

Never had issues until the new update. 
Noticed we weren’t getting any surround or sub while watching tv. 
lLiving room set up is Arc, two One SL’s and sub. I have two Era 100 but have t had any issues with them as a stereo pair. 
Back to the living room… Arc plays tv ok but can’t add the surrounds or sub to it. I can add the sub to the One SL’s but even then I can’t play anything through them if I wanted to add the sound from the Arc or Era’s. 
Tried all the resetting of devices and networks, just need it sorted now 🤦🏻‍♂️

Userlevel 1

Can not add services or modify them. Even my existing apple music does not work since I updated the sonos app

Reply