Problems with Google Play Music

  • 3 October 2014
  • 11 replies

Hi Everybody! After adding to sonos my google play account, The uploaded music
doesn´t appear (but when I log to my account in the PC or directly in the google play app , everything is ok) neither in my iphone nor in the desktop controller.

I´ve checked the configuration of my account and my PC and the IOs appear as "authorized".

I've tried removing and re-adding the service, re-authorizing the service etc. too and same problem. Help!!!!

I´ve updated to iOS8 and still wrong.

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

11 replies

Userlevel 7
Badge +26
Hi Mikel,

Are you still having trouble with Google Play Music? If the tracks aren't updating you can try removing and readding your Google Play Music account from Sonos, then add it back in. You can remove or add a service under Manage > Service Settings.

If you're still having trouble, can you please submit a diagnostic and reply back with your confirmation number?

Hi Ryan!

Last night I removed the Google play account and updated to 5.1 the IOS app and the desktop Controller; then I reauthorized my account and... OK! Now I can use Google play!

Thanks a lot for your answer and interest
Userlevel 2
Hi again all,

I have exacly the same problem as described by Ryan above. Google play works fine on other devices than the Sonos controller. I have tried removing and reautorizing the Google Play account. Same problem on Windows, Mac and iOS, songs available.

Any suggestions appreciated.

best regards,

Userlevel 6
Badge +3
You should try sending a diagnostic report when you are having the problem. A Sonos rep then can identify what's going on if you can reply here with the confirmation number.
Hello - similar issue here; music is on Google Play, and I can see a listing of all songs within the desktop Sonos app, but nothing shows when trying to view by album / artist. Have disconnected and reconnected Play service to no avail. Issue is the same on Android Sonos app as well as desktop. Diagnostics ref #7180323
I have the same issue, which started last night. I can see my playlist, and list of songs, but if browse by artist, album, or genre, no music is found.I've tried removing and adding my google play account, but that did not solve the issue.

edit: this issue is replicated on my windows laptop, android phone, and amazon kindle fire
Same issue, started today; no artists or albums, just songs and playlists. Same issue on Galaxy S5 and Google tablet. Unpluged the entire house; rebooted, reloaded the app, etc., etc. -- nada.

However, I found that if I "touched" the album in Google Play, then Sonos would recognize all its attributes. I got 550+ albums, so that tedious exercise ain't happening. Get it fixed!
looks like it's clear this issue started last night
Same issue here, and as tlithgow said, I'm not about to reload all my albums. I can access all my saved music directly omn Google Play, but NOT through any Sonos app - correct the issue!!!
I tried to remove Google Play, reinstall it and then authorized it again with no change. Sent a diagnostic report (#7182014) - not happy that you are not able to add what issue you are sending the report in for.
Userlevel 5
Badge +3
Hey mmuir, jamesey, tlithgow, and Tom P. - On the day you all reported the issue with browsing on Google Play Music there was an outage that has since been resolved.

If you're still experiencing an issue browsing on Googe Play Music, let me know. In your reply, please include a new diagnostic.