Problem starting a radio on LiveOne using ANDROID controller

Userlevel 1
  • Contributor I
  • 7 replies

Since the last app update I can’t start a LiveOne radio from an android controller, I just receive the message ‘Something went wrong’

However, I can:

  • play an album from LiveOne from the Android controller
  • start a LiveOne radio from the Windows and IOS controller

I tried to reboot everything, remove the service from the account, remove the app from the device, reboot the device … no success.

Also, it looks like the ‘SLEEP TIMER’ was removed in the latest version - or let’s say that I can’t find it anymore.

Any suggestion will be greatly appreciated :)



13 replies

I am in the same boat as P_S. LiveOne is among the best music apps that no longer works with the latest update. When can we expect a resolution? 

Userlevel 2

My wife cooks dinners playing LiveOne Late Night Jazz station.  Now I Only get "something went wrong" and lousy tasting dinners and a cranky woman…


I’m getting the same message as well for LiveOne.  It’s the streaming service I use the most.  Can we get this fixed???

The new app is a mess.

As info for the rest of you, I waited about 22 minutes to chat with the Sonos tech and all they came up with was to remove the LiveOne service and re-add it to fix it. It's like the classic "restart and it'll fix everything" kind of solution. I encouraged him to add the "solution" to the Community but I see that hasn't happened yet either. 


Hope it works for y'all! I will try it tonight.

Userlevel 1

Well, I tried that .. and that did not help

The interesting thing is that it is working properly with the IOS version, as well as the Windows version of the controller, so it is not a problem with account.

So at this time, the solution I chose was to roll back to the previous version of android controller by downloading the 16.1 APK from

and I got the sleep time back too :) )



Userlevel 1

Ditto here. LiveOne will not play. 

Good to know. I appreciate you going through the steps and posting your results. Now I won't waste my time. 


We're still looking at you @Sonos for a fix. Silly this wasn't addressed prior to the release of the app. 

I have the same problem, tried disconnect/reconnect of liveone, reauthorize. Can see and choose stations in liveone, then when try to play get "something went wrong" message. 

Sonos please fix this!!

I tried all the steps prescribed by @Sonos but it didn't fix anything. I reverted back to the last version which is better, but still not a great app. I guess they put all their tech into the speakers and not the app to control them. Pretty sad. 

Also having LiveOne and issues with playing music from Plex as well. 

Still no fix. Still no attempt at a solution. Thanks @Sonos 

Same exact problem here.

It also seems like SiriusXM might also be broken. I get no content when I select it, and the re-authorization process seems to fail after I login on the web site and return to the app.

(I really wish the Sonos desktop app was actually capable of working across subnets, because then it would be a fallback. But that’s more of a permanent long-term rant.)

Userlevel 1


Version 80.02.05 released 20240603 seems to fix the problem with LiveOne.

Sleep timer is back too!