Answered

Plex not playing newly added items in 15.4

  • 28 May 2023
  • 1 reply
  • 252 views

Hi,

 

I recently added some music to my plex server. When I try to play it via the Sonos Plex integration, I only get “Unable to play xy - The connection to Plex was lost”. This only affects the newly added music - the “old” one just works fine (I added some music a couple of days before I did the update to 15.4 - this one works). Plex itself works, I can play the newly added music via the Plex apps.

Just before I did the update to 15.4 I didn’t had those issues.

After that I tried to:

  • upgrade the server to the newest version
  • reauthorize the plex integration in Sonos
  • Switched off all Sonos devices for a few minutes

nothing helped so far.

Does anyone have similar issues or any idea? It would really help me to track down the issue.

icon

Best answer by H.Ramone 28 May 2023, 15:50

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

1 reply

Ok, I found the issue:

From the plex server error log:

Streaming Resource: Bandwidth exceeded: 2147483647 kbps > 40000 kbps

Turning off the upload limit in plex (settings → remote access) solved the issue. I don’t know (yet) who’s to blame for the max int value for the bit rate. Could be the program I use to convert the CD to flac (shamefully I have to admit that I use Windows Media Player which might have been updated without my knowledge), Plex (unlikely since no changes) or Sonos.

Note: using the Plex app with “Connect to device” and redirecting the output to Sonos worked even with the bandwith limit in place.

Maybe this post helps somebody who ran into the same problem.