Music Library doesnt index

  • 28 November 2021
  • 16 replies


The other day I noticed all of my music was gone from my library, I confirmed the path to the files is still loaded.  I hit update music library now and indexing flashes and goes away.nothing is added to the library.  I know the file permissions are set correctly because the last play list still plays the songs from the folder.  The music folder is on the hard drive of the same WIN10 PC I am trying to update from.


I sent a diagnostics report “Your confirmation number is: 812575149.”


Please help!



16 replies

Perhaps try removing the library, then reboot your speakers and try the library setup/re-indexing again.


I removed the Library.

Unplugged all of the units and plug back in to force a reboot.

Rebooted the PC the library and Sonos controller is on.

Added the library back in the app.

Clicked update music library

Same thing happened, indexing flashes and then goes away.

I can still load an old play list I saved in the Sonos app and it plays, so the Sonos speakers can clearly see the music files.


Please help!

Hmmm 🤔…Do you perhaps ever use a tag viewer/editor to view your library and the tracks metadata.. something like MP3Tag or similar software? I’m just wondering if a viewer/editor, like that, can read/play your library tracks - it might be worth a quick check to see if all is well with the tag information stored in your files too. 

Also have you tried setting up the library using a mobile controller App instead of the desktop controller and are you able to see/play your shared library files from a network connected mobile device using a different App such as ‘File Explorer/ES File Explorer’ or similar?



I confirmed the base files will play on other music players.

I have deleted the sharing permissions on the iTunes folder and added them back to confirm the share properties are not corrupted.

I can delete the library on both the PC app and an iOS device.  I can not added it back from the mobile app I get the error 900 code.  I have used REGEDIT to confirm IRPStackSize is set to dec 24 on the windows PC where the music files are.

I have my VPN off.

I also confirmed that from the base music file I can cast it from the PC to the Beam and SONOS one’s.

The frustrating thing is it work just fine a few weeks ago and then poof the library is gone and indexing just flashes.

I dont know how to get SONOS tech support to chime in.

The IRPStackSize stuff relates to SMB file sharing, which Sonos no longer uses to access files off a PC. It has its own HTTP Windows service which installs at the same time as the controller. 

If you haven’t already done so I’d suggest

  • removing the library from Sonos
  • uninstalling the Sonos controller from the PC
  • rebooting the PC
  • reinstalling the controller
  • setting up the library afresh

Ive tried everything else so far and SONOS tech support now says they can only help me on the phone… So Ill try this...


No luck…

Now on hold with SONOS tech support…



No luck with tech support, might be a file sharing issue…

I dug deeper and found the SonosLibraryService not running.

It causes two errors in event viewer:

“application Error”

   D:\Program Files (x86)\SonosV2\SonosLibraryService.exe

“.NET Runtime”

Framework Version: v4.0.30319
Description: The process was terminated due to an unhandled exception.
Exception Info: System.ArgumentException
at System.Diagnostics.EventLog.CreateEventSource(System.Diagnostics.EventSourceCreationData)
at SonosLibraryService.Service..ctor()
at SonosLibraryService.Program.Main() 


Anythoughts, I just did a clean reload but can try again…


Is your .NET fully up to date? It typically receives updates every so often on Patch Tuesdays.


yes a ran an update check and nothing pending.

All critical/important and recommended updates? Which version of Windows? 


Windows 10, version 21H2


All critical and cumulative patches installed.


I have been playing with copy folders to various places and they will work at first, but then on a second music library update they go away.  It feels like the index file is corrupted so it will show a new song and then if you delete the folder and add it back it wont add it back because it thinks its in the index.  SONOS tech support said my index was quite large even though nothing shows up to me and the last queue plays the songs just fine.  That doesn't sound like a sharing permission issue to me.


Any other ideas on how to rebuild a possibly curupted music index other than a full factory reset on all of the devices?

Its been a month with no ability to add new music, please help!!!!

Userlevel 7
Badge +22

A factory reset rarely fixes anything, often it makes them worse.

See the official Sonos guidance that tells you to save that for when told to by Sonos Support.

Userlevel 3
Badge +1

Did this ever get resolved?  I have ahd the same probolem for the pasy year but it is slightly different, fro now anyway.  For a while I have had to click on ‘update music library’twice before it woudl actually index.  Today it was three times.  Ominous maybe….

Userlevel 3
Badge +1

Just gone into controller to update and this time it won’t work, not even on 2nd or 3rd attempt.  Sonos, any ideas on this?