Controlling Sonos players without WiFi.

Is it possible to control Sonos players outside a WiFi network? Every once and a while I take my Play 5 and my NAS to work along with my CR100 controller which was not dependent on WiFi to operate everything. Now that they're no longer supported, how do I access my Music Library and Play 5 without WiFi? Could my phone be the WiFi network? I've never tried it, hence the question.

Best answer by ratty 3 May 2018, 13:10

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

11 replies

Userlevel 7
Badge +22
Sonos has a Windows and a Mac controller, you might try them.

If your phone is Android (don't know about Apple) you can set the controller running on it to tap into the SonosNet WiFi mesh directly.

You might use your phone as a WiFi hotspot, keep an eye on your data usage.

A travel router to plug into your work network and provide you WiFi might work too.
I have an Android phone with T-mobile and it has that mobile hot spot. There is no WiFi at work. That's what I liked about the CR100, I could plug in my Player and the controller didn't care if you were on a network or not. When I tried my phone the first time, it said there were no WiFi networks available and I was dead in the water. The app works fine at the house with the WiFi turned on. So, would I have to have another device to use as the controller while using the phone as the hot spot? Or, is it possible to do both on the same phone? How do I tap into the SonosNet directly?
Your phone can't act as a hotspot and control Sonos at the same time.

Have you (1) been plugging the PLAY:5 and NAS into a wired network at work, or (2) simply wiring the NAS directly to the P:5 and not connecting to any network (standalone mode)?

Either way, you'll need to configure your phone to connect to SonosNet. Do this at home, via Advanced Settings in the controller. A new SSID entry will appear in your phone's WiFi settings. Connect to it and test it out.


For option (1) above, just take P:5, NAS and phone to work. Connect to the SonosNet SSID and you're done.


For option (2) it gets a bit more complicated, but with a small tweak the Android phone can connect to the PLAY:5 whilst that's standalone. What you'll need to do is:
- edit the network settings for the SonosNet SSID on the phone
- specify a static IP address of with a network prefix length of 16
- ignore the gateway and DNS items, but if it demands entries put as the gateway and as DNS

When the PLAY:5 is standalone at work your phone should now connect to the SonosNet SSID.

Note that the SonosNet SSID now won't work back at home, since the IP won't match your home network. You'll need to connect to your router's WiFi as you currently do.


If you want to undo all of this and start over, just disable the SonosNet connection in Advanced Settings.
I plug the NAS into the P5 and would use the CR100 to control it - no network connection. I didn't know about the other stuff and I'm already at work, dead in the water. I miss the CR100.
Then it's option (2) above. Your NAS must already revert to Auto-IP addressing.
Evidently, I still have to do the SSID thing from home. When you turn on the app it looks for a WiFi connection and finding none, it reverts back to screen saying it needs WiFi.
That's what I said in my post.
I guess you missed the part that I was already at work. I'll have to worry about it some other time.
I didn't miss anything. I simply said "Do this at home...".
Has anyone EASILY played Google Music to Sonos, over Android, WITHOUT the Controller App?

I'm using Sonos for the first time at an Airbnb, perplexed how this Samsung Galaxy tablet plays to Sonos, but every Galaxy phone we try doesn't.

The solution is obviously to install the app on the phone. But I'd like to learn why it's working on a tablet without the app. THANKS
Because that tablet has been linked to the Google Play Music account that is installed on the Sonos. If you do not have access to the account, you cannot link to it.