Adding speakers and components on older firmware with v80 app

Userlevel 2
Badge +1

I have been able to add a Sonos Port on a recent firmware version using the new v80 App (iOS). However, a second Port that was on a much older firmware version can simply not be added. I have also been unable to add a Sonos One (also on older firmware) - in this case the speaker is partly added to the system but then the mandatory firmware update fails during the setup process. I have tried this on: (1) Different networks. (2) Wired and wireless. (3) On my existing and a new Sonos account.

I tried to downgrade to S1 to attempt updates this way - but the downgrade option has not been developed for v80 App and is not listed on the roadmap (so I assume this will take some time).

Has anybody been able to find other workarounds? Sonos customer support is uncontactable due to all the App issues resulting in customer service being overloaded but it also seems that customer service just blames the Wi-Fi network which cannot be the case for me as I tried this on two networks.

2 replies

Userlevel 2
Badge +1

For anyone having this issue with Sonos One’s, the following worked for me after many attempts (the Port is still not working):

  • I used the new iOS v80 App to add the speaker. The process fails during the update but the speaker then seems to be “partly” connected. 
  • I then opened the Mac app and it found the speaker but asked for an update. Doing the update via the Mac app then appears to work.
  • I then went back to iOS app to finish adding the speaker and name the room etc. 

Unfortunately, this does not work for my Sonos Port (that is currently on older firmware). Hopefully the Sonos team fixes this sooner rather than later….

Thank you OP! You have saved my old Sonos Play 1 which was tossed in my garage for over 3 years and I had no clue how to fix it.

I can confirm that I can repeat the same process to update my Sonos Play 1 as OP posted and use it with the v80 app. Before the update, my Play 1 was on firmware version 12.2.2 (build 61183220) which was last updated in the end of 2020. After resetting and connecting to WiFi with my iOS app, I successfully updated the firmware to 16.2 (build 79052294) using the mac app. Now I can enjoy my good old speaker again. 😁