Wired setup refusing to connect

  • 27 November 2020
  • 14 replies
  • 659 views

Badge

Hi,

 

I have a problem switching my Sonos setup to wired connection (due to dropouts in wireless mode).

 

I am trying to connect Sonos speakers to the same DHCP service when wired as when they are wireless (wired and wireless connection share the same VLAN, as my phone on which Im trying to set this up does - since it works in wireless, the problem shouldn’t be there). Ethernet cable is in tact (i even see there is some traffic on the port when I look into the switch web interface), however when I try to disable wifi in Sonos app/when I turn off the SSID to which they connect, do not get a connection (can’t even ping the device). When i look at IP:1400/status/ifconfig after it gets back online to wireless, it shows under eth0 that majority of RX packets were dropped… This is weird, since it goes through exactly the same switches, as my AP and it enters the router through the same trunk - I don’t see any way how when it goes through AP it would get accepted, but when it goes through cable it does not. I have disabled any and all firewalls on the VLAN and I tripple checked there is a untagged port to the correct VLAN as well as the same pVID on the port where I connect cable to Sonos… The only information I get from IGMP snooping is an IP on the given VLAN - 239.255.255.250.

 

I had the setup working in previous home where I ultimately put the Sonos on a separate VLAN, which was a hair-pulling event by itself, however this time Im not even able to make it switch from wireless to wired… Anyone has any idea what to try next please?

 

P.S. I have the same issue on 2 separate Ones and a Beam.


This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

14 replies

however when I try to disable wifi in Sonos app

Kindly elaborate. You should not be ‘disabling WiFi’ in any of the device settings. This kills the radio entirely, and SonosNet with it. You’d be wanting go to Settings/System/Networks and removing the WiFi SSID there once everything is up and running. 

 

Badge

Hi, thank you for the response.

 

Disable wifi: I tried 3 different approaches,

1. Removing ssid from network settings in app as you described,

2. Disabling wifi in the settings for the specific prosuct (resulting in error message that I should ensure ethernet cable is connected),

3. Disabling the ssid on the access point

 

in neither of these options can i even ping the IP of the speaker, let alone see it in the app (irrelevant for the last one, as phone loses connection too). There also is no IP given by DHCP when I turn off the speaker, disable ssid on ap, restart dhcp service and then power on speaker with ethernet cable plugged in...

You’ve wired one Sonos component, yes? And that’s not accessible from the wired network at all? If so it sounds like the switch port has blocked, possibly due to spotting the STP BPDUs. 

Badge

Exactly. Port works ok for other devices and I dont truly understand the BPDU protection problematic, ill try disable loopback prevention when i come to the setup, as to my understanding its the closest setting I have on the switch

Is there more than one Sonos device wired then? Loopback prevention shouldn’t be relevant if there’s only one Sonos wired.

However it wouldn’t be a surprise if STP needs to be enabled on the switch and/or tolerance of incoming STP traffic. Cisco PortFast BPDU guard, or equivalent, could be reacting and shutting off the port.

Badge

Firstly, thank you so much for your help.

There is only one Sonos device wired at the moment (I tried all of them sequentially, always only having one plugged in/included in the app), there are however other things connected to the switch (2 other switches, one upstream towards the router, one downstream to another room). As I said, my knowledge regarding BPDU is virtually non existent, its connected to a TP Link TL-SG105e rev4 and ive just reviewed the web UI, there is no setting which would resemble anything of that kind that I could identify…

However, since this would be switch specific, Ive tried to plug it straight into the EdgeRouter, which allowed me to ping the device - it works as expected, allowing me to remove SSID in the app and resuming to work normally - therefore the problem clearly lies in the switch port - which is weird, since it worked with the exact same switch in my last home…

 

Thank you very much for your help in identifying the problem. Do you have any idea what I could try to do to make it work through the TP link switch? Keeping all Sonos devices directly in the router is not an option…

 

Edit: After some search it seems there is no setting for BPDU protection, as there should be none on this switch…

BPDU = Bridge Protocol Data Unit, i.e. the traffic type for STP (Spanning Tree Protocol). I can find no mention in the user guide, though it was only a quick scan. It’s not clear how the loop prevention feature works.

It may be clutching at straws but I’d suggest you (a) make sure all the VLAN parameters are configured correctly and (b) enable IGMP snooping. 

Badge

Thanks, I went through the web UI, which only allows me to set throughput limits on ports (disabled), IGMP snooping (which is on), Report message suppression (which is off), LAG (not used), loop prevention, VLANs (802.1Q used with the ethernet port which Sonos connects to having only one untagged VLAN assigned - same one as in 802.1Q PVID) and QoS (which has DSCP/802.1P Based selected, as there is no “off” option, however no subsequent settings are applied). I cannot think of anything I’m doing wrong when it comes to VLAN - the link continues through trunk upstream and other devices are ok with it...

 

I also looked through two different user manuals, neither of which even mentions anything like BPDU… I have also not found any console documentation for the switch (I tried to ssh into it with my username and no response), so I assume it doesn’t come with one… 

 

Is it possible the switch just wont work for Sonos any more? :(

Is it possible the switch just wont work for Sonos any more? :(

Well I looked at https://support.sonos.com/s/article/41, but that’s quite probably incomplete.

 

Badge

Thanks for the page. It gives me hope.

 

i tried to reset the switch to factory and plug it with only one vlan on the upstream, still shows tons of dropped packages… If i may pick your brain for one more thing - do you know about some dirt cheap ‘truly unmanaged’ switches i could buy as a buffer between the tp links and sonos to make it work? Or could the problem still persist?

Netgear unmanaged switches (such as GS2xx) should work fine, apart from anything mentioned in the linked article.

Badge

Thanks! just to make sure, are you saying that a setup with |Sonos speaker|----eth_cable---|Netgear GS205|---eth_cable---|TL Switch|---eth_cable---|router| should work ok, or would the whole connection require to be made without the TL switch anywhere in between?

And since in such case I would be using those switches literally only as “buffer” for the Sonos speakers, I was hoping for something cheaper - is it to be expected that something super basic like D-Link GO-SW-5E will not be able to solve my issue?

A Netgear GS208 is cheaper than that D-Link switch, at least here. 

Such a dumb switch alone would work fine. I don’t know what if any packet mangling the TL switch does for VLANs so I’m afraid it’s a case of YMMV for the chain you sketched out.  

Badge

The D-Link is half the price here, thats why I mentioned it. Thank you so much for your time, i will buy it and try it out, maybe I will be in luck and won’t need to purchase a whole set of new switches :)