Symfonisk speaker became highly unreliable - SOLVED by connecting a speaker to ethernet to force SonosNet use

  • 26 March 2022
  • 3 replies
  • 567 views

Badge

I wanted to share how I solved an annoying problem with my setup in case it helps anybody else.

 

Set-up: Beam, Sub, 2 x One as a surround-sound set in one room; One in kitchen, near router; Symfonisk in study. None of them connected to ethernet.

 

Problem: Everything worked perfectly (for months) until, earlier this week, the Symfonisk stopped connecting. The white light was on, but the app couldn’t see it, and if I pressed the play button, the LED just flashed red.

 

Failed attempts to resolve: I tried everything (or so I thought) to diagnose and fix this.  Rebooting Symfonisk, rebooting router, rebooting other Sonos components. I did a factory reset on Symfonisk multiple times. I tried setting it up with and without ethernet connected. I tried changing channels on the wifi router. You name it. 

 

Result: It didn’t matter what I tried. I could sometimes get the Symfonisk to appear in the app again, but it would invariably disappear from the app when I tried to use it, or cause the app to hang.  And it seemed to be upsetting the other components, too… they would disappear from the app, and I think I even caught them sometimes spontaneously rebooting. Complete mess.

 

Further research: In the end, I went back to basics - which is where I guess I should have begun. I googled all the terms/codes that appear in the app - ‘associated product’, ‘WM’, ‘OTP’, etc, etc… maybe there was something here that would tell me that the config was just ‘wrong’ in some way.  I noticed that some components had WM:1, others WM:2.  I wondered what that meant, and discovered this page. It seemed to check out: the surrounds/sub were WM:2 (bonded in a surround set-up), and everything else was WM:1 (wireless). Wireless is good, right? That’s what Sonos is supposed to be!  So no obvious problems...

 

A-ha moment: And then I stumbled upon an article (that I now can’t find) that explained that WM:0 (wired) isn’t what a newcomer might think.  To somebody untrained in Sonos terminology, ‘wired’ just sounds like ‘this speaker is connected to the router via Ethernet’ - and why would I want to do that? It just uses up a port and creates yet more cable clutter, right? It’s entirely non-obvious to a non-expert that ‘WM:0 (wired)’ actually means “this is how you force the system to use SonosNet!” A ha!

 

Solution: So I plugged the kitchen One into the router, did another factory reset of the Symfonisk to be safe and - hey presto - everything now works.  All devices are WM:0 and the Symfonisk actually works. I still have no idea why it *stopped* working, but at least I now have a working set up.

 

I’m sure what I’ve just written is obvious to the experts but I genuinely had no idea you were supposed to have one of the devices wired in - or that it can at least help solve problems if, for some reason, regular wifi isn’t working.  So I’m sharing it here in case other people didn’t know this either.


This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

3 replies

SonosNet (‘wired mode’) was the original connection method. The option to connect directly to WiFi came much later. SonosNet is frequently recommended where there appear to be intractable WiFi problems. 

SonosNet’s strengths persist: it’s an extensible mesh and directs audio traffic onto its own dedicated channel. On the downside, SonosNet’s throughput is constrained by a 20MHz channel in the crowded 2.4GHz band.

 

If you’re interested in understanding how your Symfonisk unit is now connecting, point a browser to http://x.x.x.x:1400/support/review, where x.x.x.x is the IP address of any player, and display the Network Matrix. There are many threads here explaining its contents, but if you’d like comment then post a screenshot.

Badge

Many thanks. Matrix below (only ‘Western Kitchen’ is playing anything right now in case that’s important; it also happens to be the device with an ethernet question). I’m hoping this suggest all is now good?  

 

Excellent signal strengths and no obvious interference. That said, the latest models can’t display their ambient noise levels in the matrix (hence the white cells in the left column) and it is just one snapshot. Hopefully things will remain satisfactory.