Speakers in a Group drop out when audio switches

Show first post

53 replies

Userlevel 2
Badge +4

Thanks for the replies! So, the only thing that is hard wired to the router is the Boost and the Connect is hard wired to the Boost. 


I will try to raise the Boost’s location. I noticed something when the issue seems to be present. I come in the next morning and the only speaker connected is the “Studio Left Wall” speaker. Sure, I hit the icon and add the rest of the speakers or press “everywhere” and they are supposed to connect, yes, they connect but like before it takes about 20 seconds before the do. 


I removed the boost completely and this did not resolve the issue at all. I also manually added each speaker back into the system and the problem went away but later presented itself once again. 


I have not messed with the wifi or the wifi settings yet. Also, Stanley_4 the link you left is broken and does not pull up a page.  


Appreciate all the help

Userlevel 7
Badge +22

Also here: 


Presumably the Boost is wired and you are running all on SonosNet.

So perhaps see if this helps to improve things for you…

  1. Set the main routers 2.4Ghz WiFi band to use a ‘fixed’ (least-used) non-overlapping channel. Use either channel 1, 6 or 11 and if the router allows, set the channel-width to 20MHz only.
  2. Goto “Settings/System/Network” and set the SonosNet channel so that it is at least 5 channels away from your chosen router channel in Step 1 above.
  3. Whilst in the Network Settings in the Sonos App, if present, remove your routers WiFi credentials, as these are not required when running your system with one Sonos device wired to the router.
  4. Set the Boost at least one metre away from the router and place high so that it and your speakers are above head height, so that the bodies in your class are not interfering with the wireless signals 

See if that then improves your Sonos connectivity.