Sonos One disconnected overnight "WiFi password incorrect" fix.

  • 20 October 2019
  • 30 replies
  • 18517 views


Show first post
This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

30 replies

I did see some posts about Sonos being able to connect to 5Ghz networks, so maybe that happened when the 2,4Ghz network was shut.

If there is some incompatibility with authenticating on 2.4GHz on Orbi systems then there ought to be some kind of application note made available for us!

Userlevel 7
Badge +17

If there is, and enough people call it in, I'm sure Sonos will notice it….

Hi, I had the same experience today, just woke up and no speakers were connected to WiFi, powering off and on did not help, etc.  Play:1 and Play:5 on S2 12.1.

Plugging in a network cable and deleting / attempting to rejoin the network only resulted in WiFi password incorrect, even after a factory reset.

I eventually solved after finding this thread.  Had to disable 5GHz (make it 2.4GHz only) on my WiFi network, then I was able to join OK.  Have since re-enabled 5GHz and restarted the speakers and they join OK.

If it happens again I guess I’ll just setup a separate SSID as a 2.4GHz only network for Sonos.

My router, switch and AP are all UniFi gear, if it makes a difference, but sounds like this is happening to everyone.

OK, if I factory default the Play:1, conect direct to router with ethernet. Configure the Wireless Password while connected using the ethernet, then remove the ethernet and reset, it DOES login to the Orbi WiFi and I can stream again.

Halelujah!

Userlevel 7
Badge +23

Logins have been an issue for routers that have 802.11b/g disabled (ie 802.11n-only).