Sonos Connect - cannot factory reset (flashing orange-white, never green)

  • 2 November 2022
  • 16 replies


I hope you can help me reset my Sonos Connect.

After applying power with the pause button depressed, then releasing the pause button after about 15 seconds:

  • the led flashes white/orange forever
  • the led does not transition to green.
  • the network port (cable connected) flashes so the switch and network is working.

I have tried other combinations many times without success.

Any ideas please?  



16 replies

Hi.  Failure to factory reset normally indicates a hardware failure.  What is the back story here?  Why are you trying to reset the device?

Thank you for you fast reply!

After running successfully for two years, the Connect was powered down for 3 weeks while I was away. 

When I returned the Connect powered up only to the stage of having a flashing white LED.    The Sonos app could not see the Connect to bring it into the Sonos system.

I tried a factory reset that did not result in a flashing orange-white but never a permanent green LED.

Interestingly, the Connect often transmitted an SSID for a connection, and the Sonos app did sometimes see the Connect, to connect to it, but the remainder of that installation frose at that point (the Sonos app did not progress with the installation).

So I tried more factory resets that failed (flaashing white-orange but no green led)

I think the Connect might have a corrupted OS-Software. 

 - Is there a way to write the a base load software directly to the Connect?
 - is there a way to debug a Connect that does not factory reset?

I feel like the hardware is OK, but the software might be corrupted.   I don’t want to be forced into buying a new box for this simple prioblem.

Thanks in advance for any help.


As a test, wire the CONNECT to the LAN.

In general, Factory Reset complicates issues.

When you wire to the LAN, lack of or erratic port lights indicates hardware failure.

Thank you for your help,

The Connect is connected to the LAN and the port lights are flashing as per normal.

Still no reset ….

I have exactly the same issue, was any fix found?

Same issue. Sonos Connect working fine. Gone for 3ish weeks, when I come back app can not detect and can not factory reset. Nothing here ?

Have you tried to call Sonos Support directly to discuss it?

This is suspicious, could Sonos have deliberately sabotaged the Sonos Connect, or made a mistake in the software update? I also have the same problem here.

I have had contact with Sonos Support and conclusion was: device is dead, that’s what orange-white flashing light after factory reset means.

More likely caused by the Illuminati. 

I am having this exact issue as well. I had this connect in storage for over a year. Pull it out, plug it in, orange and white flashing, never goes green. I see it on the network, but can’t connect to it. Factory reset does nothing. Nothing about the network or set up has changed. It was just in storage. 

What did Sonos support say about it, when you called in?

Exact same issue here. According to this post 

my Connect’s manufacturing date is August 2015. I’m trying to downgrade to S1 without succes. In the middle of the process my Connect doesn’t seem to be able to connect to my home network, neither by wifi nor by ethernet cable. In the ethernet connected case, I see a steady green LED and a blinking yellow LED on the ethernet port.

So, what did Sonos Support say, when you contacted them?

They told me that unfortunately my Connect is broken and not repairable. I could start an RMA procedure. I‘d need to send back my Connect in order to get a 30% discount on a new device.

Same issue. I can get all the way to this screen with my connect amp but the flashing light never goes green this is where everthing dead ends as a result. Did everyone give up on this issue?

There has to be a fix somehow.


Userlevel 2

I have exactly the same fault with mine? Stuck on flashing Orange/White after reset never goes green. Just happened this week - all other SONOS devices functioning correctly. There must be a rabbit away somewhere.. will call SONOS support tomorrow and see what they say.