Sonos causing Mac crash

  • 18 October 2019
  • 20 replies

I’m on the latest macOS Catalina 10.15, and my Sonos controller is up to date. On three occasions recently opening the controller on my Mac has caused the whole computer to instantly crash - I’m hoping someone might have an idea why? Thanks, Shane


Best answer by controlav 19 October 2019, 16:54

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

20 replies

That certainly seems unusual. Have you submitted the crash statistics to Apple for review? And then submitted a system diagnostic to Sonos, for similar review?


Not that it helps you much, but I’m not having that issue on two different Catalina installed Macs. Any possibility that there’s a firewall or perhaps a virus protection application that is killing the app? It would seem odd to only occur occasionally. Which is why perhaps sending that diagnostic in to Sonos might help, since they would likely see an error in the log files that are part of that submission. 


Edit: Not that you’ll get any feedback from Apple on it. However, if you post the diagnostic number here, or better yet contact Sonos Support with the diagnostic number, you’re much more likely to get feedback.

Thanks Bruce. 

I submitted reports to both Sonos and Apple. It’s not the app that crashes per se, it’s the whole Mac shuts down instantly and reboots. I did wonder if it was an issue with Norton, I checked the firewall permissions and Sonos had ‘Always’ checked for permission access.

How do I find the diagnostic number?



Userlevel 7
Badge +22

If the entire machine is crashing then its an OS bug. Apps should never be capable of bringing down an operating system. Not since Windows 95 anyway.

Bruce’s reference to a diagnostic number was assuming an app problem, but this is way beyond that. I have no idea how you would report an OS bug to Apple.

Oh really? It only happens when I load the Sonos controller 🤔

Usually, when a Mac crashed completely (and it’s relatively rare, in my experience), when it comes back up, there’s a “submit crash statistics to Apple” that pops up, although this may not be as common as it used to be, since they now ask you when setting up a new version of the OS if you’re willing to submit crash statistics to Apple.

The diagnostic from Sonos would be after running the process in the app itself. It gives a resulting number at the end of the process, once it’s saved the data off on Sonos’ servers, which you would make note of, and then contact Sonos about. Without a prompt, Sonos wouldn’t look at it, as noted in the [url=]Diagnostics - How do they work?[/url] thread.

All of this being said, I do tend to agree with controlav, this does not seem to be a Sonos issue, in my mind at least, and there’s something else going on.

I’d certainly delete the current copy, and download a fresh one from the Sonos website, on the offhand chance that the copy you currently have is oddly corrupted.

Hey @ shanebenton I am having the same problem where my whole MacBook Pro crashes and I am suspicious of Sonos as well.

Here’s why (from “problem report for macOS”):

panic(cpu 2 caller 0xffffff800cef715e): "soreceive: sb 0xffffff803e8bd4e0 so 0xffffff803e8bd478 cc 1448 mbcnt 2304 mb 0xffffff8122feeb00 mbtail 0xffffff8122feeb00 " "lastrecord 0xffffff8122feeb00\n"@/BuildRoot/Library/Caches/
Backtrace (CPU 2), Frame : Return Address
0xffffff914122ba30 : 0xffffff800c939a3b 
0xffffff914122ba80 : 0xffffff800ca70fe5 
0xffffff914122bac0 : 0xffffff800ca62a5e 
0xffffff914122bb10 : 0xffffff800c8e0a40 
0xffffff914122bb30 : 0xffffff800c939127 
0xffffff914122bc30 : 0xffffff800c93950b 
0xffffff914122bc80 : 0xffffff800d0d17f9 
0xffffff914122bcf0 : 0xffffff800cef715e 
0xffffff914122bd20 : 0xffffff800cee9b7b 
0xffffff914122be30 : 0xffffff800ceb6752 
0xffffff914122bee0 : 0xffffff800ceb648a 
0xffffff914122bf40 : 0xffffff800cf9a1aa 
0xffffff914122bfa0 : 0xffffff800c8e1206 

BSD process name corresponding to current thread: Sonos

Mac OS version:

I’m working through it with Apple to see if they can figure it out, but very suspicious of Sonos controller app if you are having the same problem… and it seems to be getting called out in the problem report for macOS.


I’m having the SAME EXACT issue.  Started when I switched to Catalina.  Kernel panic and system crash fairly consistent when I try to open the controller.  


It’s to the point that I don’t even want to open the macOS controller, and run Sonos from my phone instead.  I have to make a deliberate risk decision on whether I’m willing to restart and open all my apps/windows/work before I choose to open Sonos.


Currently on macOS 10.15.2.  I even completely wiped the system and did a clean install of Catalina but the issue remains.  I’m also in the most current version on all controllers and devices.  I submit the crash report to Apple every time it happens.


Looking forward to a fix/solution.

Oddly, I’m not experiencing this issue, on either of my Macs. Have you submitted a system diagnostic within 10 minutes of experiencing this issue, and then contact Sonos Support to discuss it, so that they have some data about the situation on which to investigate the issue? Or are you expecting the anecdotal post to be enough to generate this “fix/solution” to something that doesn’t appear to be endemic?



Thank you for your great suggestion on submitting diagnostics and contacting Sonos support.  I’ll consider doing that in the future.


However, you I don’t appreciate your snarky follow-up.  “Or are you expecting the anecdotal post to be enough to generate this “fix/solution” to something that doesn’t appear to be endemic?”


We can be helpful and respectful without being sarcastic or demeaning.  I intend to offer the same level of respect to members of the community that I expect from others.  Thanks for your support and consideration.


macOS just crashed again after Norton asked permission for incoming connections when opening the macOS controller.  Diagnostic 343909729 immediately after reboot.

Thanks, Sonos support!

Userlevel 5
Badge +16

Hello again, @sonosamas.

I even still have your diagnostic up here on the screen to look over from the other thread. I’m also inclined to believe that this is a security setting within your Mac itself, are you running any other security programs than Norton? You may want to check the settings for Norton 360 and Mac OS firewall to make sure that everything is inline. If the settings are correct and your mac still crashes, we would need the crash logs themselves. In this case I would suggest starting a support ticket with us so we can take care of this with you.    




@Jean C. Thanks for your insights.  I had a long remote troubleshooting session with Norton a few days ago.  They adjusted my firewall settings and told me everything is properly configured.  I kinda don’t trust them because I had to go back and clean up some app exclusions that they forgot to add.  Also, even with all the exclusions set they way they say will work -- the system still crashes frequently.

All of that to say I think Norton is the culprit, but am not sure how/what to fix.  I haven’t yet followed up with Norton (need a space where I can blow 1-2 hours with their tech support).

I’m on the phone with Sonos support now to open a ticket.  Hopefully between Sonos, Norton, and Apple (yeah right...) we can find a solution.

Thanks again!

Userlevel 5
Badge +16

Hi @sonosamas, that sounds like a party alright. 

I also suspect that Norton is the culprit but without remote access myself I could only speculate on which toggle is astray.

Keep us posted on your progress and we’ll all be happy to assist you further if necessary. 



@Jean C. Support case number.

They think it’s Norton and told me to check back with them.  Will send update on Norton when available.

Appreciate your support.


Moderator Note: Personal Information edited

@sonosamas Any further insight into this issue? I have exactly the same problem, running Catalina 10.15.4, Norton and Sonos. I deleted a previous version of Sonos, downloaded a new version and still the same thing happens -- the whole system crashes to a black screen of death shortly after I launch Sonos.  Any help would be helpful.



@lapnews I suggest opening a support ticket with Sonos.  Include a Sonos diagnostic and the crash report(s).

I wasted countless hours with Norton support and their only solution was to remove/reinstall.  I reinstalled Norton at least 8 times over the course of several months.  This never fixed the problem and Norton wasn’t interested in doing additional research.

I haven’t checked with Apple, but I expect them to blame Sonos or Norton based on past experience with another macOS issue.

This isn’t quite a “fix” but I recently removed Norton and switched to McAfee.  My employer just started a home use program, so it didn’t cost me anything to switch.

Results???  TWO WEEKS with no crashes whatsoever!  With Norton, my system often crashed even without Sonos as a preceding event.  Everything is running smoothly after the swap.

In summary, I don’t know if a “fix” is yet available -- but the problem seems to lie with Norton, and removing Norton correlates with my crashes going away.  To Sonos’ credit, they at least wanted to investigate the problem further.  Norton just wanted to reinstall whenever I raised the issue.  YMMV contacting Apple.

Hope this helps.

@sonosamas Tnx for the thoughtful reply. I will do as you suggest and open the Sonos ticket. Resisting the idea of replacing Norton for various reasons, but maybe it’ll come to that.


Hey, all, this is *definitely* a Norton issue, in my opinion. I’ve been running the Sonos controller on my Mac for years with no problems. Just installed Norton this week and now boom - every time I start Sonos, I get prompted for whether to allow a connection from one of the Sonos devices. I say Allow, and within 10-15 seconds, I get the black screen of death. Tried fiddling with the Norton settings, but it doesn’t help. Norton will be removed from my laptop ASAP.

I agree with Nigel as I get exactly the same symptoms. 

Exactly the same issue. Current OS. Deleted app from MacBook Pro and downloaded latest version. When I launch app I receive notice that network device wants access, then immediately have instant shutdown. I am using Norton Security. If Norton *is* the culprit, any suggestions on best alternatives?

FWIW, I’ve used Norton literally for decades with no issues, so it feels rather silly to replace an effective app because this has *only* ever happened with the Sonos app!