Sonos Beam - update error- error code 49

  • 22 November 2020
  • 3 replies


I own a sonos beam. On my iphone app i can see an available firmware update. When i try to update i get error 49. 
I have tried first rebooting the beam and then also tried doing a factory reset. However, both did not work. 
My sonos 2 app is latest - no pending app update. 
Please advise. 

Best answer by memav7 24 November 2020, 18:40

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

3 replies

Userlevel 5
Badge +16

Hi @memav7, thank you for reaching out to us, and welcome to the Sonos community. We appreciate your detailed post describing the issue and all your effort in checking this from your end. Let me help you out with this.

First I'd like to ask questions to isolate the issue so we can create a path towards resolution.

  1. What is the light status on your Sonos Beam after the factory reset? Is it flashing green?
  2. Have you tried hard wiring your Sonos Beam to your router? What happened?
  3. Did you try to reset the Sonos app from your mobile device?
    • In the Sonos app > Settings > App Preference> Reset App

Please submit a diagnostic report from your Sonos system for us to check. Just include the confirmation number in your response so that we can look up the information. Let us know how you get on with the advice above. We'll wait for your reply.

Thanks Rowena! 

1,2 did not work. 

3 worked for me.




Userlevel 5
Badge +16

Hi @memav7, thank you for your response and for updating us. I’m glad that your Sonos system is working again. Please do not hesitate to reach out if you have further questions or concerns. We are always happy to help out.