Playing different Spotify content in different rooms no longer working



Show first post
This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

62 replies

Opened a discussion today in the morning about this exact topic, but in German SONOS forum …

Using SONOS für 3 years, right now 4 Play:1 and 1 Move.

Problem started to occur yesterday in the evening.

Hope that it is fixed when I’m at home today in the evening; post by @ullefutz makes me hope for the best. 

Badge

It’s working again for us as well!!!  Thanks Sonos!  

As a note, I have automatic updates enabled, but didn’t have to manually apply a new update.  So, it either updated itself to a new version or they fixed it on the backend without creating a need to update locally.

Badge

It’s working again for us as well!!!  Thanks Sonos!  

As a note, I have automatic updates enabled, but didn’t have to manually apply a new update.  So, it either updated itself to a new version or they fixed it on the backend without creating a need to update locally.


Spotify fixed the problem. 😉 And I can confirm it’s fixed.

 

https://community.spotify.com/t5/Other-Partners-Web-Player-etc/Different-music-in-different-rooms-Sonos/td-p/5191774/page/2

Yea, it’s hard to conceive of this as being a Sonos issue, since the stream isn’t handled by Sonos at all until the point it reaches the speaker. I suspect they had a misconfigure of their server, but that’s only a guess. 

Badge

It’s working again for us as well!!!  Thanks Sonos!  

As a note, I have automatic updates enabled, but didn’t have to manually apply a new update.  So, it either updated itself to a new version or they fixed it on the backend without creating a need to update locally.


Spotify fixed the problem. 😉 And I can confirm it’s fixed.

 

https://community.spotify.com/t5/Other-Partners-Web-Player-etc/Different-music-in-different-rooms-Sonos/td-p/5191774/page/2

I was guessing it was a Spotify problem, but Sonos had to work with them to resolve the issue.  

I can confirm its now working again too - thanks to the Community for raising the issue and Sonos/Spotify for resolving it.  

 

What a relief!

I’m frustrated to tears. I can’t get back the hours I’ve poured into this. My Sonos is acting like I’m trying to play multiple streams from Spotify except I can’t even play ONE stream. It’s unusable. How can I fix this from my end? I’ve exhausted every forum, every article, every q&a. I’ve disconnected and reconnected the sonos, force signed out all Spotify logins, etc. I want to just return all my Sonos speakers at this point. I’ve spent two hours just today working on it… not to mention all the other days from when I added the roam speakers. 

Userlevel 7
Badge +17

Have you tried contacting Sonos?

Yep. Waiting for a response. Looks like this problem goes all the way back to 2016… hopefully there’s a solution. 

I have the same exact problem except the error message I receive is "unable to play (song name), connection to spotify was lost" Prior to last week, everything was working perfectly. A few days ago, I could stream the same song to different rooms, but couldn't stream different songs to different rooms. And now, I can't even stream to any room. Please help!

Update: After unplugging all of the speakers, I can confirm everything is functioning back to normal! 

I have found that the Sonos Roam cannot switch spotify accounts. I can ask my Sonos One to switch accounts and it works every time. Hopefully this will get fixed.