New network. No Sonos

  • 13 October 2020
  • 6 replies

Long story short, I upgraded my ISP connection, which prompted me to upgrade my router/firewall. I also decided to replace my very noisy dying switch. Result, great network, but Sonos is being very difficult. First, Apple Music stopped working. Couldn’t fix it. So being an idiot, I factory reset all of my Sonos. Managed to get 4 Play:1 connected (3 rooms, one each, except for one room with a pair). Now, trying to add any more Sonos results in a network problem on the last step of the process.

My network: BT Openreach → Fortigate 80F → Netgear 752TPv2 → Ruckus AP

  • BT Openreach = ISP termination point in my house. CAT 6 connection to Router
  • Fortigate 80F = Router & Firewall
  • Netgear 752TPv2 = 48 port switch
  • Ruckus AP = WiFi access points. All are wired to switch, so not a mesh network.

Everything used to work prior to the router and switch upgrade.

I’ve tried changing the MTU on the router; I’ve adjusted STP settings on the switch, and enabled “Forward BPDU while STP Disabled”. Nothing seems to work.

Any ideas? Thank you.


Best answer by willphillipson 16 October 2020, 13:20

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

6 replies

Userlevel 6
Badge +17

Hi @willphillipson.

Welcome to the Sonos community and thanks for reaching out to us. The behavior of your Sonos system is not normal. Allow me to share with you some guides to help out.

 You may want to check out this article if you have rooms missing from the Sonos app.

Commonly, this issue can come as a result of wireless interference. Are you perhaps using an incompatible network configuration or hardware that does not meet our system requirements?

If all of the above checks out, you may wish to set static IP addresses to the devices on your Sonos system, some routers have an issue maintaining a connection with devices that remain on the home network. We may want to consider bypassing the FortiGate 80F router&firewall as well as the Netgear switch and connect Sonos directly to the main router. I would also want to add that Sonos does not support a corporate type of network set up as there are security layers and feature that creates communication failures both locally and to the internet with plug and play devices such as Sonos.

Here are router settings that need to be verified. You can contact your ISP or the manufacturer of the router for assistance.

a. Auto channel must be set to Off

b. Choose the best non-overlapping channel (1,6,11)

c. Set channel bandwidth to 20MHz

d. Both 2.4GHz and 5GHz should be enabled

e. UPnP should be enabled

f. 802.11 band should be set to b/g/n

g. Airtime Fairness should be disabled

I hope this helps.

Please let me know if you still have further questions or concerns. We are always here to help.


Hi @Paul A,

I have reserved DHCP IP addresses based on the Sonos MAC addresses. I’ve verified the rest of your recommendations as best as possible. And this is a very flat network - there is no other router or device involved - my FortiGate connects directly to the ISP.

What I find fascinating is that 4 Play:1 speakers across 3 rooms are working fine. It’s just the process of adding my other speakers into the mix that fails. The error I receive is a “Wi-Fi connection problem” at the very last step of the process (from what I understand). This occurs regardless of whether the speaker is wireless or wired.

As a side note, which may be related, I’m unable to submit diagnostics from my laptop or the mobile app. (Except once yesterday, when all of the Sonos were turned off and unplugged!)

I’ll try calling support again (last two attempts have resulted in being cut off prematurely, unfortunately!)



e. UPnP should be enabled

This is a dangerous and unnecessary recommendation. Router UPnP is for gateway control, which is nothing to do with Sonos’ UPnP AV. Router UPnP is a well known security vulnerability and should, in almost all circumstances, be disabled. 

There have been rare occurrences where bug-ridden router code would cause its UPnP setting to affect Sonos’ SSDP player discovery but these issues should now be in the distant past.



The STP settings are not relevant if you have no more than one Sonos device wired to the network.

I suggest you check around for anything which could be blocking multicasts and broadcasts. Try toggling IGMP Snooping settings.

I take it you're not using VLANs?

Hi @ratty


My FG doesn’t support UPnP for that very reason… :-) But it’s enabled everywhere else.

No Sonos currently wired to the network. I used to have my Playbar and my connect wired, but they’re both currently unplugged as I try to figure this out.

I’ve enabled multicast and broadcast. 

I just disabled IGMP Snooping on my switch, and it enabled a different system that was also experiencing issues with TuneIn broadcasts. So maybe that was it. I’ll test and report back.





Quick update for posterity.

Everything is now working (well, at least the Sonos and Control4 systems which were having problems earlier.)

Seems to have been the IGMP Snooping.

On my Netgear switch (GS752TPv2):

  • disable “Auto-Video Status”
  • disable “IGMP Snooping Status”
  • enable “Spanning Tree State”
  • set “STP Operation Mode” to “RSTP”
  • enable “Forward BPDU while STP Disabled”
  • enable on all ports “STP Status”
  • disable on all ports “BPDU Forwarding”

I also ensured that broadcast and multicast abilities were enabled on my router.

Thank you @Paul A and @ratty for your assistance.

Userlevel 6
Badge +17

Hi @willphillipson.

Thanks for the update and immediate response.

I’m glad that everything is now working and thanks for sharing what was done to get things working again. I do hope you continue to love and enjoy your music and Sonos.

Please do not hesitate to reach out or create a topic if you still have further questions or concerns. We are always here to help.