Long silence

  • 24 January 2021
  • 7 replies

Userlevel 1

Here’s the dilemma: I play music from my Mac; from YouTube, or the music app with my own music files loaded, or streaming from various sites, all using Airplay 2. I have 2 SL 1’s paired in ‘Living Room’. Also have a 5 in the kitchen I only use on occasion so I leave it out of the loop. I’ve no other Sonos equipment. Everything sounds very nice…..until I resume the music after I pause it to do whatever from around 2 min or longer. It then takes at least 15 sec or never for the 1’s to start playing again. The volume icon in the menu bar stays set to ‘living room’ unless I switch it to internal speakers. If I then switch it back to ‘living room’, no sound. I have to keep switching it back and forth, and then the 1’s finally decide to resume playing. Any ideas about why this long silence when using airplay from my Mac and how to prevent the problem? I’ve tried the line in option, same problem. Thanks.   

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

7 replies

Userlevel 6
Badge +16

Hi there @Soundog, thanks for reaching out. Sorry to know about this long silence issue on your system, Son that e can take a look at the current status of your Sonos system, please submit a diagnostic and respond with the confirmation number. This way we can identify the cause of this issue.

Let us know how it goes and we're here to answer any further questions you have.

Userlevel 1

Here is my diagnostic # 1705664404

Try turning off AutoPlay on the input for the Mac’s signal. I believe that kills the ‘silence timer’. You’d have to explicitly choose that input, but I think that would be an effective workaround. 

Userlevel 4
Badge +6

Maybe I misunderstood, but @Airgetlam is AutoPlay relevant to @Soundog ‘s use case?  It sounded like AirPlay2 was the source, from the Mac.  For what it’s worth, I have encountered a 15-second (or *forever*, as @Soundog says) delay when using a Mac to AirPlay2, even to a stereo pair of Apple’s own HomePods!!!  Sometimes, yes, activating the Sound/Output list in the System Preferences & turning back on the computer speakers, then selecting the AirPlay2 speakers again fixes it, but sometimes not.  Ugh.

Here’s what I think is happening: Speakers are placed near the fringe of Wi-Fi reception.  This causes the Mac -- which now since AirPlay2 has “improved” buffer-ahead to prevent sound dropouts even during Wi-Fi dropouts -- to demand from the speaker that it buffer more data.  Thus 15 seconds of silence while they negotiate and ship off a buffer’s worth of sound.  And that’s assuming that the buffering itself doesn’t get hit by a drop-out!  And sometimes the speakers don’t play at all, and ¡only sometimes but not always! when that happens, they disappear, momentarily, from the speakers list on the Mac.  (I suspect Bonjour sleep proxy is responsible for them not disappearing properly even though they aren’t available on the network, but can’t prove that.) 

For the HomePods I solved long-delay and no-sound simply by moving them closer to the wireless access point.  They still buffer, but for more like 2 seconds, and they never disappear, thus no need to revert to the computer’s speakers and then select them again on the Mac.  (You could test that, or even hard-wire the One SL’s with Ethernet cables, to test if the problem goes away.)

Apologies for the long-winded response if I have indeed misunderstood, but if not, then I bet you a quarter that the diagnostic shows Wi-Fi interference (or at least a massive latency increase) of some kind.  Good luck!

[Edit: Oops, just saw the “line in” reference so AutoPlay matters, but since the One SL doesn’t have a line-in port, it’s still being *broadcast* from the Five to the Ones, with attendant interference possibilities.  Just not exactly the same obnoxious behavior like AirPlay2.  If Bonjour Sleep Proxy is responsible for the screw-up, wiring with Ethernet cables will *not* help, a big clue, and whenever the One SL’s go to sleep the same thing will keep happening.  In that case, the only remedy is to ensure that every piece of Apple equipment, especially AirPort’s if they are in use, has the latest software.  Older Mac software and older AirPlay (1) speakers on the same network will make it even more confusing -- just watch the speakers come and go in the list (even on iPads) -- it’s crazy.]

Yup, I missed the AirPlay 2 connection. Although I’m of the opinion the timeouts on AirPlay 2 aren’t a Sonos thing, but instead an Apple choice that Sonos has no control over. However, I have no proof on that. 

But you’re absolutely correct, my previous post would only apply to the line in, and not AirPlay 2. 

Userlevel 1

Thanks to all who responded. The issue persists and I have ruled out interference, having shut off Bluetooth to check. My original post stated ‘in line’, my error, I tried connecting left speaker with an ethernet cable; no difference. (or would I have to ethernet both speakers? Haven’t tried that.) The wifi range is not an issue as the speakers are within 10 feet of the router. So am I correct that this is an airplay 2 buffering issue? I’ve not yet received a diagnostic report. 

Userlevel 1

I think I have found a work-around. I play this video and minimise the tab. The Sonos thinks something is still playing but there is no sound.