Issue updating my Sonos one

  • 15 November 2020
  • 1 reply

I have been trying to update my sonos one to version 12.2 without any luck. 

I have tried all the recommended fixes,

•Moving closer to the router 

•Plugging in the speaker to the router 

•Factory reset on the speaker and then trying again.

All of these haven’t fixed my issue with the update and I still get the Error 30 when I try to update the speaker. As I live in Belgium there is no customer care contact that I can get in touch with to help. All my other speakers have updated no issue and all are running on the S2 app


If you have any idea on how to fix it I’d love to hear them, thanks



This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

1 reply

Userlevel 5
Badge +16

Hi @Verant.

Thanks for reaching out.

I appreciate your detailed post outlining the issue as well as the steps that you did, let me help and try to figure this out.

Error 30 occurs when one of your Sonos products tries to download the update file but is unsuccessful.  

It seems you’ve already followed the suggested steps that you can find in this article about Error 30 when updating Sonos.

Which Sonos product is experiencing the issue?

What happens after you factory reset it, we’re you able to add it back on the system?

What is the status of the LED light on the said Sonos product affected?


I'd like to check some data from your system. Please send in a diagnostic report through the Sonos app and reply with the confirmation number. I'd start by reviewing your system and see if there’s anything causing this issue.


I’m looking forward to assisting you further from here.

If you have any other questions or run into any issues,  please do not hesitate to reach out,  we are always here to help.