Grouping speakers "Unable to connect to the device"

  • 16 October 2020
  • 3 replies




When trying to group my speakers they often give an error message saying “unable to connect to the device” (danish: “kunne ikke oprette forbindelse til enheden”). I have tried grouping them with each other seperately like 1+2, 1+3, 1+2, 2+3 etc. but it does not work. 

Sometimes (very few times) it works, but not for very long then one of the speakers will stop playing, skipping or stopping, then begin again and such. 


I do not think it is the connection or interference since it is 4 meters away from the router and the only thing between is a drywall and a small kitchen cabinet.   


I never had any issues with Sonos before a few weeks ago?


My setup is:

Sonos Beam
1x Sonos x IKEA Symfonisk lamp

2x Sonos x IKEA Symfonisk shelve speaker


I am about to buy 2x Sonos One Gen 2. But do not want to if this problem continues. 


I have made a diagnostic: 344148001



To make sure I have tried everything. I have changed the channel from auto to 1, 6 or 11. Nothing helps. I have also tried rebooting the system and moving them closer together and connected trough ethernetcabel.
Nothing of the above works.

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

3 replies

Userlevel 5
Badge +16

Hi @Lundehoj.

Thanks for reaching out and welcome to the community!

I appreciate your detailed post outlining the issue as well as the step(s) that you did, let me help and try to figure this out.

Upon checking the diagnostic report, the system detected transport and sync errors result in audio dropout and playback failure, possibly Sonos is not getting enough bandwidth or experiencing poor wireless conditions. Commonly, these could be caused by wireless interference, or perhaps the audio feed is too slow to allow the Sonos player to maintain reliable playback.

If all the recommended steps to reduce wireless interference were followed and it doesn’t help, then knowing how and through what Sonos is connecting is the great foundation to troubleshooting this successfully.

  • May I have the make and model number of any wireless router and/or Access Point that exist on the network?

  • Please indicate also how these devices are connected to one another (wired or wireless).


I understand that you already have gone through a wired connection using an ethernet cable and I hope you won’t mind if we may need to try it again, so I can check some data on the system. If you are using a local WiFi network with more than one WiFi hub or access point, the best option is to switch your system to SonosNet by wiring just one standalone Sonos device to your primary WiFi hub or router, that begins the WiFi network. Attempt music playback, or any other activity to Sonos that was previously failing, and see if the issue persists.

Wait for about 3 minutes, then submit a new diagnostic report and reply with the confirmation so I can check if there will be changes.


Let us know how it goes and if you have any questions feel free to reach out, we’re always here to help.


Hi @Annazel S,

I understand that it would make most sense if it was because of wireless interferences, but the speakers play with no problem alone. The only issue is when they are grouped or try to group them. Sometimes they group with no problem, and play with no problem. But then a couple of minutes later it start stopping/skipping on one or more speakers. If I play on the speaker alone/ungrouped or with only a few in the group it has no problems… 

Also they are a few meters apart. I can not possible understand how my internet should not be able to get to the Sonos speakers… 


There is only one router/access point (my apartment is 56kvm small) - My router is a (standard from wifi provider) Sagemcom Fast 3890V3.

The devices is connected wireless. 


Do you want me to make another diagnostic? The problem has not changed and I have not done anything further...


Thank you :) 

Userlevel 5
Badge +16

Hi @Lundehoj.

Thanks for your response and update.

Currently, there are no issues found using this specific model of router, however, they are susceptible to ‘groupcast issues’. 

NOTE: It has observed better performance and controller connectivity when  2.4 and 5Ghz bands are separated.

(2.4 GHz bandwidth must be set to 20 MHz only)


I suggest that it would be best to check also the IGMP (Internet Group Management Protocol) Snooping setting because it can be a problem if it is disabled.  

To enable IGMP Snooping:

  • Navigate to Advanced Setup > LAN and check Enable IGMP Snooping.
  • Select Standard Mode.
  • Then, reboot the router.


If the above advice was followed and the issue persists, please submit a new diagnostic report, and reply with the confirmation number, so I can review further and see if there’s anything else possibly causing the issue.


Let us know how it goes and if you have any questions feel free to reach out, we’re always here to help.