Connection issues with connect amp but not play1 speakers


Sonos system works fine with streamed music, and is almost fine with playing music from my WD My Cloud Home NAS directly through the speakers, but the Connect amp often finds it hard to make a connection to the NAS or begins a song and then drops out (in which case I get an error message warning me the wifi is unstable. This has been happening for a long while (years)!

We’ve been through the unplug / reset steps, and have now moved the system to a new (and supposedly faster) modem/router. Our internet service is patchy, the price of living in regional Australia with a government that crippled the national broad band network from the beginning, but while this may cause the connect amp a problem or two, it doesn’t explain why the system appears to work better when I bypass the amp.

Any suggestions / insights are welcome.

Albert


13 replies

I have just tried the amp after wiring it to the modem --- appeared to work OK though I haven’t tested it extensively. Might suggest that it is the Connect Amp’s ability to pick up the wifi that is the problem?

Albert

How far is the Amp from the router? If it’s not too far, I would go back to using WiFi and try it with the Amp/Sonos system set to use the 2.4Ghz WiFi band - set that band to a channel-width of 20Mhz only in the router settings (many routers support that option, but not all) ..and set the WiFi channel to a non-overlapping channel either 1, 6, or 11 and see if that works.

If that wireless setup doesn’t work for you, then a wired setup might then be the best option.

There’s certainly a lot of previous folks who seem to have similar experiences, mostly due to wifi interference.

Thanks Ken for your suggestion - I was initially daunted by the thought of doing this but it turned out to be relatively painless and I managed to change both the bandwidth and the wifi channel. Alas, this does not seem to have made a difference. I will try the other suggested channels though to see if any make a difference.

Thanks Bruce for the link to the info on interference. We’re relatively free from the suggested sources of interference inside the house, so I don’t think that this is the issue here - though good to check.

Since posting I have had time to work on this a bit more. I can usually (almost always) play compressed (iTunes) files through the Connect Amp with no problem. The drop outs tend to happen when I try to play uncompressed audio formats such as Apple lossless where the file sizes are quite a bit larger. I wonder if the NAS is still up to the job. Unfortunately, I am not getting much traction with the WD tech support.

Albert

Thanks Ken for your suggestion - I was initially daunted by the thought of doing this but it turned out to be relatively painless and I managed to change both the bandwidth and the wifi channel. Alas, this does not seem to have made a difference. I will try the other suggested channels though to see if any make a difference.

Thanks Bruce for the link to the info on interference. We’re relatively free from the suggested sources of interference inside the house, so I don’t think that this is the issue here - though good to check.

Since posting I have had time to work on this a bit more. I can usually (almost always) play compressed (iTunes) files through the Connect Amp with no problem. The drop outs tend to happen when I try to play uncompressed audio formats such as Apple lossless where the file sizes are quite a bit larger. I wonder if the NAS is still up to the job. Unfortunately, I am not getting much traction with the WD tech support.

Albert

When streaming audio like Apple Music - are those tracks streamed from online (iCloud) and are you using the Sonos App or Apple Music App (Airplay) - and moving onto your WD NAS box - is that wired to your router - do you have any issue streaming the tracks for playback on your mobile device?

You mentioned changing the channel/channel-width on your routers 2.4Ghz band - but can you double check that the SSID is the only one that you have listed in the Sonos App ‘Settings/System/Network/Manage Networks’. Also did you uncable all your Sonos devices from the router/LAN?

When I stream music - which is rare - it is only through Amazon music, which I access through the SONOS app. No apple. airplay (at least not deliberately!).

Usually, all of the SONOS appliances I have are ‘connected’ wirelessly. I will occasionally connect one of the devices to the router directly when checking things out. Currerntly nothing is wired into the router except for the WD MyCloud Home drive, and a desk top computer that my wife uses. No SONOS gear is wired in.

I checked what SSIDs were in the SONOS app - thanks for the very clear instructions on how to do this - and, yes, the  previous wireless network was still listed there  in addition to the new one (added three days ago). I deleted the old one, tested again and still get drop outs on the lossless (large) music files.

Albert

Is there anything ‘wireless’ near the Amp that might cause any interference? Have you considered trying it in a different positions (if convenient) to see if it makes any difference.

The other thing to perhaps consider is changing the Ethernet cable and port(s) that the NAS is currently using to see if that resolves the issue.

There is nothing obvious that I can see or think of that might be causing interference. The modem is located in a home office but the computer is wired into the router.

I did play with a replacement cable and changing the ports a while back, but that was with an old modem. I haven’t reassessed this with the new modem / posy changing the wireless settings in the router, but I will do as soon as I get a chance and will report back.

Unfortunately the amp is more or less fixed where it is. I will speak with the electrician who wired our house whether we can change the position of the router to enable me to wire the router and amp - that’s one option. The other I am considering is re-ripping my CDs using a compressed format - just for the SONOS. Big job, but it might be all that is left for me.

I really appreciate the thought you are putting into this. Thank you.

Albert

I wouldn’t bother moving the router - that sounds like too much bother and whilst transcoding the tracks to smaller compressed format may help, again I wouldn’t personally do that - particularly if the tracks are say 16/44 .flac encoded, or similar, as they should play fine - I would certainly try a different ethernet cable connection as a next (easiest) step and see if that perhaps resolves the issue.

@AlbertLabrador,
Another option open to you, is that when you next encounter an audio dropout issue to immediately submit a system diagnostic report (asap and within 10 minutes of the issue) and post the reference back here and then go onto contact Sonos Support via this LINK and see if the Staff can see where the issue may lie and perhaps help you to pinpoint and resolve things.

You could try replacing the Ethernet cable on the WD NAS and a reboot if not done recently.

 

Also you could temporarily physically move the NAS to near the connect and use the spare Ethernet port to connect it and see if that helps.

 

As for re-ripping, you just drop your existing tracks into a converter and transcode to another format keeping all your artwork and metadata. On my M1 Mac Mini it’s less than five seconds to do this per album but It does have SSD drives and the tracks local (not on a NAS) when doing this,

Hi everybody

First many many thanks for your contribution to helping me get this all to work. Its been an interesting and frustrating experience. I took a few days away from worrying about this and then came back to all of your suggestions (plus my own - probably misguided - thoughts).

After a morning of nothing but ‘no connection’ error messages, I have now managed to play four large file songs without interference or drop out. Too early for me yet to rejoice but the answer appears to lie in a mix of the things that people have suggested here, which I had tried without success earlier but now worked again in different combinations. I changed the channel again (from 6 to 11) and tried more ethernet cables and all four ports. The oldest of the cables I have to hand seems to have worked the trick.

I’ll keep the testing going for the rest of the day (enables me to say I’m working while listening to music!) and get back if the issue resurfaces, but for the moment (fingers crossed), I think your help has cracked the problem (he said stroking his rabbit’s foot and trying to find his four leaf clover).

All the best

Alan

Spoke too soon. By evening the drop outs and lost connections had returned, and if anything were worse than before. A bit more digging around suggests that this could be the precursor of a fault with one of other of the drives in the WD My Cloud Home. As a last resort, I tried a Factory Reset this morning. This should have only taken 30 minutes according to WD support, but is yet to complete 5 hours later. The flashing LED can mean one of 6 or 7 things (!) … but two of them relate to drive failures.

I am finally going to pull the plug on the drive.

Reply