Connect (GEN 2) suddenly out of sync

After four years of perfection, one of my Connect (GEN2) started lagging behind all the other Sonos speakers. Happens regardless of the source (TV, PC, Sonos App using Spotify, etc.). Have always used Sonos Net. Unplugged the Connect, waited 10 minutes, plugged it back in and made no difference. Tried the same with the Sonos Boost (ethernet connected to the router), then the router itself, and still the same lag only in the two B&O towers connected to the Connect (GEN2). The other Connect (GEN2) still in perfect sync (also connected to two B&O towers). The only difference between the two is the one out of sync has Hardware Version and the other is I’ve also tried changing wireless channels, to no avail. I have the app on three phones and a PC, all using version 14.18. Any ideas?


Best answer by Corry P 2 November 2022, 16:22

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

23 replies

I suggest swapping the Connects to see whether the problem follows the Connect or stays with the speakers. 

Do the speakers have any sound processing settings?

No, the B&O towers do not. But I did discover, through my own ignorance, that the other B&O towers are indeed out of sync as well. My highly unofficial test was standing on the staircase and listening downstairs, and I had thought they were in sync, but upon testing a second time they were not. So, the issue is with the Connect (GEN2) in general, not the one specific box. This happened after the latest Sonos update, so perhaps the Connect (GEN2) system is simply outdated, thus forcing me to buy the newer Port system?

No, the B&O towers do not. But I did discover, through my own ignorance, that the other B&O towers are indeed out of sync as well. My highly unofficial test was standing on the staircase and listening downstairs, and I had thought they were in sync, but upon testing a second time they were not. So, the issue is with the Connect (GEN2) in general, not the one specific box. This happened after the latest Sonos update, so perhaps the Connect (GEN2) system is simply outdated, thus forcing me to buy the newer Port system?

Hi, Sorry, but if you are going to make ridiculous suggestions like that, there is no point trying to work out what is really going on.  


I don’t get it, what was a “ridiculous suggestion?” I’m simply trying to understand how and why both Connect’s are suddenly out of sync, and what my options are for fixing it. I apologize if my wording was somehow twisted into something different.

Are you seriously suggesting Sonos would deliberately sabotage a product used by hundreds if thousands of its customers in order to force them to replace them? 

Even if one were a total cynic, it should be clear that this would risk  colossal reputational damage. It would be an insane thing for Sonos to do.

OK. My first observation would be that if this were happening to all Connects there would probably be dozens of posts about it by now. So I suspect, although cannot be sure, that this is something specific to your system. 

Can I check. Do you have another Sonos speaker fairly close to the Connect, and you can hear they are out of sync?

(Speakers don't have to be that far apart before the time for sound to travel between speakers creates an echo effect. )

Ah, now I get it...sorry, I’m not THAT cynical, just sadly used to product obsolescence I suppose (PC’s, phones, etc.). Yes, there is a Playbar between the two towers underneath a Samsung TV and a Play:3 about 30 feet away on the far side of the kitchen, both of which are still in sync. My Roam, along with the Beam and two Play:1’s upstairs for the Master Bedroom TV, are all still in sync.

The towers appear to be just split second behind, but it’s enough to make everything sound like an echo, and therefore annoying as hell...

I just tried using the Beam as the source throughout the entire house, and upon cranking the B&O towers, they were out of sync. Running off my PC as the source has the same results.

It seems apparent that the Connect’s are the lone culprit. There are no settings other than “variable or fixed” Line-Out levels, and they’ve been in sync all these years up until the latest Sonos app update. Admittedly, I did not notice the issue immediately after the update, but that could simply be because I hadn’t cranked up the volume for any particular reason until a football game last weekend. 

Thank you for trying to help.

I know this will sound like a stock response, but if you haven't already tried this I think you should power off all Sonos devices and your router and the B&O speakers. Power the router fully back up, then any wired Sonos devices, then wirelwss Sonos and the B&Os.

Incidentally, do you have any wired Sonos Devices?

I’ll give it a try...

Yes, the Sonos Boost is the lone device wired directly to the router, thus using the SonosNet for wireless connections. Turning that off and waiting a few minutes was my second troubleshooting test after trying the same with the Connect box. I did reset the router but did not unplug any Sonos devices at the same time. 

I cannot explain why one CONNECT might suddenly have an issue while another may not.

With your testing, be aware that sound travel in air is pokey at about one foot per millisecond. Consider the situation where speakers ‘A’ and ‘B’ are separated by 30 feet and both are connected to the same amplifier. Lets assume that the same length of wire connects both speakers and we don’t need to consider signal travel time differences in the wire. A listener standing near ‘A’ will claim that ‘B’ is 30ms late and a listener standing near ‘B’ will claim that ‘A’ is 30ms late. A listener ‘C’ standing midway between ‘A’ and ‘B’ will claim that the speakers are time aligned. All three observers will be correct.

Userlevel 4
Badge +3

I‘ve had exactly the same issue with my Connect since the 14.18 update - 


Unplugged router...unplugged every Sonos device and all 4 B&O towers...waited almost an hour...plugged router in first...waited almost 15 minutes for everything to settle...then started with the Sonos Boost (hardwired to the router), and slowly but methodically plugged all Sonos devices and B&O speakers back in and…

Voila! it worked! But…

After about 10 minutes the echoing began again, and the sole culprit were the speakers connected to both Connect’s (GEN2).

Now I see another user (DunkirkPie) has the same issue since the last update, so at least it’s not only my system, but alas, the issue still exists ☹️ Thanks, John B for being patient and trying to help.

Guess I’ll just have to wait for another update. Either that or break down and purchase a couple of “Ports” (just kidding...)


Yes it certainly looks like you are not alone. It may (or may not) be the case that other conditions need to apply for the sync to be lost.

Did you form your group by starting from a Connect or another device, or did you try both?

For years I’ve only had one group called MAIN, and it connects (no pun intended) the Playbar under the TV, the Play:1 in the kitchen and the two B&O towers through the Connect (GEN2). The grouping always begins with the Playbar, which is ARC connected to the TV. So...I just tried grouping with the Connect first, which didn’t work because turning on the TV immediately connected with the Playbar, so I forced the Connect to connect to the TV as a source, even though the TV was off, and quickly added the Playbar and the Play:1. Again, it worked, with perfect syncing, but only for a few minutes, after which the B&O’s began lagging behind the Playbar and the Play:1.

Good suggestion (I wouldn’t have thought of it), but to no avail.

Userlevel 7
Badge +18

Hi @RichardCarnes 

Welcome to the Sonos Community!

I recommend you end troubleshooting and get in touch with our technical support team regarding this issue - it’s the only way this will get resolved.


I have this issue too!!!!  I’ve been on the phone with Sonos customer support twice today and their “answer” is that it’s because my Connect is on a different network than the rest of my system.  I have a Netgear Orbi Mesh system so the speakers are going to be on different home satellites.  Was not an issue for years until a few days ago.  They’re pleading ignorance on it being their problem.

Userlevel 7
Badge +18

Hi @BigMCA 

Sorry to hear that. It can be quite difficult for agents to be aware of certain issues if they don’t search for the right phrase - especially if they are particularly uncommon issues.

I can only ask you to please get back in touch with our technical support team and ask the agent you speak to to search their documentation for “clock pull”. I can’t guarantee that they’ll find that particular issue in your diagnostics (I haven’t seen them), but if they do, they’ll then know what to do with it.

I hope this helps.

Userlevel 4
Badge +3

FYI I was having this issue and it has now been resolved:


I’m now on call #5 with this issue.  It seems they’re almost at the point to replace it, but of course want to try just one more test.  It’s pretty damn infuriating.

I’m having the exact same issue! A Connect (S2) is initially in sync with the rest of the Sonos network and then falls out of sync over time. The audio source has always been the Sonos app (not line in) and the audio system connected to the Connect is old-school analog, no DSP in it. It’s been working for years and now is frustratingly unstable. I’ve been on chats and calls with support many times. I’ve spent a Saturday running an Ethernet cable through the house so I could hardwire the connection from the router to the Connect as well as a Sonos Five that has always been directly wired to the router (now both the Connect and the Five are wired).  It still falls out of sync. Cycling power to everything in the network will fix the problem, for a while, and then the Connect will fall out of sync again. I’ll get on the phone with support again on Monday but is there any way I can point them to this thread?

I’ve also started experiencing this problem recently.  The Connect gets out of sync to create an echo effect.  Sometimes it starts ok, but develops the problem over time.  Have tried both analog and digital outputs.

Hi Friends - just an update from my side.  Previous summary: I’ve got a Sonos network with 8 end points, S2, wired network (Sonos Net) with a Five hardwired to the router.  One of the end points is a Connect that’s been replaced once already (a couple years ago?) due to it developing electrical noise in the output when line-in was selected as the source.  The Connect has started falling out of sync with the rest of the network.  Through multiple support calls, I’ve run endless permutations on the wireless network, switched from Sonos Net to wifi, and hardwired the Connect and another Five into the router (so as many as 3 hardwired endpoints).  The problem persists.  It’ll go away after resetting the Connect but slowly reappears over a few hours.

In the last phone session with support (last week), the tech again was hyperfocused on the wireless network despite the Connect and the original Five both being hardwired and still losing sync with each other.

They offered to upgrade the Connect with a new one for 30% off (the path I’ve been through before).  I haven’t done that for fear the new Connect will behave like the old one.

The workaround I’ve developed: I’ve semi-permanently hard-wired the Connect to the router with 35 feet of Cat6 cable, and if I select the Connect as the head node in its group, the problem doesn’t appear.  There might be a slight phase mismatch between the Connect and the other speakers, but it might be me being hypersensitive to the issue now.  (It might be in my head.). I’ve left the original Five as also hardwired to the router.  I’ve taken out the third hardwired connection; it didn’t seem to help.

I’m going to stick with this for now while I watch the forums to see if the problem is found and solved.

I might consider just throwing more money at the problem and replacing the Connect with a Port, if I can gain confidence that it would solve the problem.  I’ll search around here to see what issues might be emerging (or not, as the case may be).

I’m curious if anyone has experience with replacing the Connect with another Connect or a Port.  Please post if you have…

I haven’t been following this closely, but there seemed to me to be enough people having this issue around the same time to suspect there may be a problem that needs looking into.  I haven’t yet noticed an acknowledgement from Sonos that this may be the case (but that doesn’t mean there hasn’t been one).