Connect Amp: I have 3 rooms Connect Amp in media room with 4 in-ceiling speakers, a bar with 2 in-ceiling speakers and a workout room with 2 in-ceiling speakers

  • 16 November 2020
  • 3 replies

I’m trying to play the same source thru all three but I can’t get media room source into the two other rooms.  All speakers work individually but when I want all speakers to play the media room I only get a hiss at top volume from the other rooms. 

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

3 replies

Userlevel 5
Badge +16

Hi @Connect sys, thank you for reaching out to us, and welcome to the Sonos community. We appreciate your time and effort in bringing this concern to us. Let me help you with this. Have you tried grouping your speakers in the Sonos app? Please submit a diagnostic report from your Sonos system for us to check. Just include the confirmation number in your response so that we can look up the information. If you need help with any other information, feel free to reach out. We'll wait for your reply.

Yes, I cannot send the media from the theater source to the two other rooms.  Can you confirm the connections for a connect to a Denon Receiver AVR-2400H to be able to do this?


Everything works independently just fine.  I can use my TV/Music sources for the Bar or the Workout room and either can be the source for either or both rooms and play simultaneously but I can’t get the theater, connected to the Sonos Connect, to play as the source for either the Bar or the Workout room, which again both have their own amp.


Thanks.    Diagnostic # 1705163974

Userlevel 5
Badge +16

Hi @Connect sys, thank you for your response and for submitting the diagnostic. Let me help you out with this.

Based on the diagnostic, there's interference in your wireless network that is caused by wireless congestion, and audio dropouts due to sync errors. This could be the reason why you’re having an issue. Also, the line-in connection is detected on your Sonos Connect.

Let me suggest the following steps to see if this would work for you.

  1. Change SonosNet channel
    • Changing the wireless channel is a troubleshooting step in reducing wireless interference.
    • Settings tab, select System > Network > SonosNet Channel > Change the wireless channel to 11
  2. Group your speakers
    • Test audio playback if you will encounter audio skipping on each speaker
  3. Interferences may be also one of the causes of a weak wireless connection.  
    • Move away from the devices from your Sonos speakers or turn them off. 
    • Check Sonos if there's an improvement with the performance.
    • Relocate the affected speaker(s) to determine if it is a wireless range issue.
  4. If you have access to your router settings, below are the settings that need to be verified. You can contact your Interner Service Provider or router manufacturer for assistance.
    • The auto channel must be set to Off
    • Choose the best non-overlapping channel (1,6,11)
    • Set channel bandwidth to 20MHz
    • Both 2.4GHz and 5GHz should be enabled
    • UPnP should be enabled
    • 802.11 bands should be set to b/g/n
    • Airtime Fairness should be disabled (if applicable)
  5. Reboot your network devices and all your Sonos speakers

If you're still experiencing audio stop or skip, I recommend contacting our Sonos Customer Care support with your full network setup including the make and model of each device, and for more in-depth troubleshooting steps to provide you the best option.

If you need help with any other information, please be sure to let us know. The Sonos Community is always here to help.