Answered

Cannot connect Sonos One to new ASUS Router

  • 4 January 2021
  • 11 replies
  • 4308 views

I just purchased and set up a new ASUS-RT-AC86U/CA Dual Band Wireless Router. I have tried several times to connect the Sonos One to no avail. I searched this community and found an answer from 3 years ago. I moved the Sonos One right next to the router. I adjusted the router settings per the community answer to: wireless menu>>Professional Tab>>Airtime Fairness - and disabled. I tried the setup through the Sonos App on my iPhone but it did not work (the Sonos network does not appear in wifi settings). So then I used the alternative set up and plugged the speaker directly into the router. The speaker worked instantly. I could play music from the app and I could use the Hey Google command. So then I moved the Sonos One back to where I originally had it placed. I plugged it in, went to the app and it showed the many stations I could connect to but when I tried, it says it cannot locate the Sonos One. The Hey Google only answers that it’s not connected to the internet. I tried again, from the new location, to connect it both wireless (again, no sonos network) and by an ethernet cable that I have in its new location. It will not work. Any suggestions?

icon

Best answer by ratty 4 January 2021, 23:04

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

11 replies

Userlevel 7
Badge +22

Did you enable B/G mode on the router’s WiFi?

There is a checklist in the FAQ on getting a new router working if that isn’t it.

Thanks for your reply. The wireless mode on the router is set at Auto with the box b/g Protection clicked and greyed out. So yes.

Did you actually configure the WiFi credentials into the One whilst it was wired to the router?

Settings/System/Network/Wireless Setup

Yes. Everything was working perfectly until I unplugged and moved the Sonos One back to its permanent spot.

Userlevel 7
Badge +22

Plug it back into the router, power cycle it and wait 15 minutes for the logs to fill. Submit a diagnostic and post the number here for support to look at or contact them with the number by other means.

That will let them look at internal data we users can’t see and verify the radio is working properly.

Userlevel 7
Badge +23

This ASUS router was not compatible with Sonos with the latest firmware. You need to use an older firmware version on the router. Then yell at ASUS to fix it.

Userlevel 7
Badge +23

 

controlav - I’m not sure what you are saying in your reply.

controlav - sorry, I see that the second message showing up is just a repeat of my question title.

controlav posted a link to a different thread in which the same issue is discussed. 

Solved:

  1. I reset the Sonos One.
  2. I reset the Sonos App on my iPhone
  3. I moved the Sonos One right next to the ASUS router and connected to the router.
  4. I had the router app open and could see Sonos was now connected. It still took a few tries to get it to add to my network even though it showed it was online on the router app.
  5. I reviewed the above suggestions and also more google searching and realized that I had indeed skipped the step that ratty (above) had stated - Settings/System/Network/Wireless Setup (prior to me posting this question, I had the speaker working after many attempts and it stopped when I just unplugged) - NOTE - I COULD NOT GET TO THIS STEP UNTIL I MOVED THE SPEAKER DIRECTLY NEXT TO THE ROUTER.
  6. Once I did that, I unplugged from the router and power and moved the speaker where I wanted it. Plugged it back in and it works.
  7. Previous to the above, I followed controlav’s link and turned off the auto-priority/QoS settings in the router - I DON’T KNOW IF THIS HELPED OR IF I CAN TURN IT BACK ON?
  8. The Sonos One is connected to my 5G network and is now working including Google Assistant.

Thank you to everyone for your help - greatly appreciated!! :relaxed: