Can't connect devices to account

  • 2 April 2021
  • 1 reply


I was having some wifi drops with my ISP router, so I bought an Tp-Link Archer c80. I set it up in AP mode and began migrating everything to the new networks. 

I disabled the old wifi networks and everything was good until I tried to set my sonos equipments.

I have a playbar and a sub(gen2) on the living room and a play:1 in the bedroom.


I’ve spent a few hours around this I cannot get the speakers to work. They show up in my system with the IP’s the router assigned, but each time I try to start playing something I get a generic error (can’t add to playlist 701).

I tried everything I remembered, reseting both routers, wiping app data, reinstalling app, changing wifi channel to 1,6 or 11, etc.

I then disconnect everything from power and did a factory reset on the playbar. I start the set up and everything goes fine, it gets discovered, added to the wifi but fails in adding device to account. 

If I clear app, try to join an existing system, it finds the play:1 or the sub, continues the set up then fails on veryfing updates with error code 800.



Any thoughts?



Best answer by joaotl 2 April 2021, 21:35

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

1 reply

All sorted. DHCP server on the second router was activated, despite being set up as access point.