Answered

Can't add my music to Sonos.

  • 20 October 2020
  • 8 replies
  • 178 views

Badge

For some reason, I can no longer add my music folder to Sonos.

I’m no “noob” having been a PC user for over 25 years and know my way around a PC, so have done this before, with no problems whatsoever.

I have just tidied up my laptop, and rearranged where my music is filed, and it now resides at C:\Users\steve\Music.

No matter what I do, Sonos will not accept that address when attempting to add that folder in the Music Library Settings. I have tried adding via the default My Music folder, and also typed the address in, hit next, and then allow the laptop to access that folder, nothing happens, it just hangs on the same screen, and when hitting the next button again, still no joy. 

I’ve also tried copying the music to another folder on the same drive, and then trying to add it that way, still no joy.

I’ve also uninstalled my Sonos app, and reinstalled it, still no joy.

My PC has not been reset in any way recently, so no issues with security prompts etc etc.

Any ideas or help to rectify this, would be most appreciated, it’s starting to drive me nuts, now!

Regards, Steve.

icon

Best answer by steveh59 20 October 2020, 00:59

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

8 replies

Badge

Seems like this is resolved now.

Opened the app, clicked “Manage” and then “Update Music Library”, and it’s now importing all my music…..doh!

 

Userlevel 6
Badge +17

Hi @steveh59.

Welcome to the Sonos community and thanks for reaching out to us and for your update. I’m glad that everything is working now and your music library has successfully updated. If I may ask, what was done to fix the issue so other members of the community that might have the same problem may find your solution helpful.

Please let us know or create a topic if you still have further questions or concerns. We are always here to help.

Thanks,

Badge

Hi Paul.

Unfortunately, the problem had not been resolved, then, but has now!

I have no legacy products so have always used S2 since its release.

I was led to believe that the indexing can take a long time, but as it still hadn’t completed by bedtime, left the laptop on all night, only to see it was still going when I woke up.

In frustration, I uninstalled the Sonos app, ran my preferred windows clean up app, rebooted, and reinstalled Sonos 2 from your website, and for whatever reason it has now managed to find my library, and imported all my music.

Just over 11000 songs took about 15 minutes.

 

Regards, Steve.

 

Userlevel 6
Badge +17

Hi @steveh59.

Thanks for the update and immediate response.

Was there by any chance you might have rebooted the router as well? This type of situation may be caused by network congestion or just like what you have explained re-installing the Sonos S2 app, possibly a system glitch. The good news is, everything is back and working again. I would recommend if this situation happens again, try submitting a diagnostic so we can check what might be going on. 

Please let us know or create a topic if you still have further questions or concerns. We are always here to help.

Thanks,

Badge

Hi Paul.

Thanks for your response, but I never rebooted the router.

If I get problems again, will bear your advice in mind.

Regards,

Steve.

Userlevel 6
Badge +17

Hi @steveh59.

Thanks for the update and immediate response.

Please keep us posted if the issue still persists. I’d recommend submitting another diagnostic after 5-10 minutes of the issue happening and posting here the confirmation number so we can check. I do hope that the issue has been fixed already.

Please do not hesitate to reach out or create a topic if you still have further questions or concerns. We are always here to help.

Thanks,

Badge

Rebooting the Router solved my problem.

Userlevel 6
Badge +17

Hi @Alan_63.

Welcome to the Sonos community and thanks for the update and sharing what resolved your issue so other members of the community who might have the same issue as yours may find your solution helpful and try it out. Rebooting the router removes any temporary data stored on the router that might be contributing to latency, lag, and possible congestion on the device. I’m glad that everything worked out. I do hope you continue to love and enjoy your Sonos.

Please do not hesitate to reach out or create a topic if you have any other issues or concerns. Here in the community, anyone can help you out.

Thanks,