Audible - song not encoded correctly

  • 8 November 2020
  • 6 replies



when I try and listen to an audiobook using audible, I got a ‘… song not encoded correctly’ error. This was working until quite recently.


any idea on how to resolve?


Best answer by Airgetlam 8 November 2020, 21:24

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

6 replies

The first thing I’d try is a reboot of your router, followed by a reboot of the speaker. If that doesn’t fix it, I would recommend that you submit a system diagnostic within 10 minutes of duplicating this problem, and call Sonos Support to discuss it, or post the number here. If you post here, it would likely help if you were to state which ‘file’ or book you’re talking about. 

There may be information included in the diagnostic that will help Sonos pinpoint the issue and help you find a solution.

When you speak directly to the phone folks, there are more options available beyond just the diagnostic analysis. 

Thanks Bruce. I’ve submitted diagnostics - 132243267 the book I’m trying to play is called The Five

I have the exact same issue with my Sonos One. If I try to play an Audible audio book from within the Sonos app it tries to play several chapters with each saying the song is not encoded correctly. If I start a book in the Audible app and then use “connect to device “ it tries to play and then stops. I can play books fine on my iPad through the same Audible app. I’ve tried resetting everything I can think of. This started a week or two ago. Also I can ask Alexa to play a book and that works but doesn’t allow using playback controls like go forward/back. Had that issue before though and using the app used to get around it. Now that I can no longer do that is annoying. 

I’m not sure what else to do.

Userlevel 5
Badge +14

Hi @Biginthe50s.

Welcome, thank you for reaching out to Sonos Community and providing a diagnostic report since you already tried all troubleshooting steps let me help you further.

Upon checking on the diagnostic report.

@Airgetlam is right to try unplugging all Sonos devices from power, then reboot your router. Once the router comes back up, plug your Sonos devices back in.

And if you can try to hardwire one of your speakers directly to the router and try to observe it for the meantime if there’s improvement since were talking about audio playback failure.

Let us know if it works. If you need help with any other information, please be sure to let us know.

Any progress with this? I've the same problem.

Sonos one no longer plays audible content.  The message is 'chapter not encoded correctly'


Issue resolved for me with a system update