Amazon prime music not playing on Sonos ZP100

  • 14 November 2020
  • 6 replies


Hi all, amazon prime music not playing on Sonos zp100. Amazon music shows up as an option BUT when I press play, I get the pop up ‘get unlimited’ and no music starts.  I don’t want unlimited just my Prime Music. Please help. What am I doing wrong?


Best answer by Rowena B. 17 November 2020, 01:57

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

6 replies

Userlevel 5
Badge +16

Hi @Yuchen2020, thank you for reaching us back here in the Sonos community. I appreciate you for sharing this with us. Let me help you with this.

First, let me ask some questions to isolate the issue so we can create a path towards resolution.

  1. When did it start happening? Were you able to play Amazon Music on your other Sonos speakers?
  2. Have you tried using another mobile controller? Did you encounter the same?
  3. Have you tried reauthorizing your Amazon music service in the Sonos app?
    • In the Sonos app, go to Settings > Services & Voice > Tap Services > Tap on Amazon Music > Reauthorize
  4. Is removing and re-adding the music services helped?

After checking the steps above and you're still having the same issue, please submit a diagnostic report to further check on this. Let us know the confirmation number. Let us know how it goes. We'll wait for your reply.


Hi, thanks for your help

1:this is the 1st time that I’ve added amazon on my S1 to control my two zp100 and one zp120. Amazon works on my ONE new gen. 
2:never used snother controller

3/4: done it multiple times

diagnostics ref: 1753796955


Does it matter if my Sonos account is in our family account and the Amazon account is in my wife’s account? They are different emails 

Userlevel 5
Badge +16

HI @Yuchen2020,  thank you for your response and for submitting the diagnostic. Let me check it for you.

There shouldn’t be an issue with the email accounts that you’re using because Sonos and Amazon are two different applications. When you mentioned in your post that you received a pop-up message saying “get unlimited”, this could be a streaming limitation for Amazon Music. You can only stream with your Amazon Music account one at a time. If someone in the family is using your Amazon account, you will get that message and you won’t be able to play music. You may reach out to Amazon to check your account.

Upon checking the diagnostic, there’s another streaming limitation error for Spotify. The report also detected an audio playback error and your Kitchen/Dining room is a dropped room - no network connectivity. To address these issues in your Sonos system, let me suggest the following steps and see if it will work for you.

  1. Hold down the Join button (or Play/pause and Volume Down button) for 10 seconds until the LED flashes RED. (If the LED doesn't respond, move on to a reboot.)
  2. If the player is already powered on (or the power cable is already plugged in), unplug the power and plug it back in.
    NOTE: Make sure the outlet is getting power.
  3. Change wireless channel on the Sonos app. Settings > System > Network > Networks > SonosNet Channel > Set it to 1

Let us know how you get on with the advice above. Please run another diagnostic for us to check and let us know the confirmation number. If you have any questions about this, let us know. 



thanks for trying with the Amazon issue. I’ve decided to NOT use Amazon. I’m not have issues with any of my rooms when I use Spotify 

Userlevel 5
Badge +16

Hi @Yuchen2020, thank you for your response and for updating us. We do understand your decision. You can still stream in Amazon Music on the Sonos app so long that no one is using the account. Please feel free to reach out in the future if you have any other questions. You're always welcome here.