Amazon music "missing required information"

For years amazon music has worked fine without issue.

Within the last few weeks it keeps failing raising an error message:

Your Amazon account is missing required information.  Please go to on a computer web browser and update your information.  It may take several minutes for your account information to update.


Going to doesn’t show anything thats an issue, the account is up to date and can play just fine through amazon.


I can remove the amazon account from sonos, then re-add it, and music will work fine for a couple hours then fail again with the same error. 


Having to do that repeatedly is a giant pain.


Any help on how I can get back to this just working?


Best answer by eandy 8 May 2022, 20:44

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

28 replies

NOTE: I do not own a Sonos product. But was thinking of switching when i started to have this issue also. I thought I would add this to the forum so people could see that it’s not just Sonos. 

I have this exact same issue streaming Amazon Prime Music (the one the comes with prime membership) on the Bose sound touch app. It has been flawless for years but all of a sudden (starting in April) it comes up and says account missing information. I sign in and my Amazon music account and it is fine. If I wait a few mins and try to start streaming again it’s fine for another few hours.


I thought May have been some sort of change because I didn’t have the unlimited plan but I see from the posts that it is happening even if you have an unlimited account.


I sure hope they fix it is super frustrating. I have attached a screen shot from the Bose app when this happens.


If you scroll through the forums this is not a specific to one device issue. This is happening on TV’s, Sono’s, Bose etc. this is an Amazon issue. 


Please fix



Userlevel 2
Badge +1


I am experiencing issues with online streaming services as well.

For a few month, when I ask Alexa (from my Sonos One) to play some music, it won’t start. When I launch some music to be played from Amazon, it will start for a few seconds, and then move to the next song and so on. Sometimes, I receive a message saying that the song is not encoded properly.

And then I tried to play Sonos Radio, same, the commercial will play and then no music.

What is weird is that when I stream music from my local network (either from my Plex server or from the local library, both on the same Nas) it works perfectly.

I tried to re-authorize my Amazon Music account. No luck.

I’d try a reboot of your router. It may need to grab updated DNS data from the internet, in order to be able to reach the various streaming servers. If that didn’t work, I’d suggest a diagnostic within ten minutes of an event, and a call to Sonos, who might be able to see something there.