Access denied to Synolog NAS server – can’t play files in one room other rooms are fine?

  • 29 April 2023
  • 56 replies

Userlevel 2
Badge +5

Access denied to Synolog NAS server – can’t play files in one room other rooms are fine?


I am a long time user of Sonos. I have 4 zones that all uses S1. I do have a Roam also (S2) but hardly ever uses it at my home.


My zones are: 


Office: two Play 5: gen1

Livingroom: Soundbar, Sub and two Play:3

Room 3: Play:1

Room 4: Play:1


I do have a booster as well. 


Out of the I can no longer play my music files from my Synology NAS – BUT only in my office…. I can play my files in the livingroom, room 3 and 4 – but NOT in my office.


I have tried from my MacBookPro App and from my iPhone app – but it will not play the files. Radio and streaming services are doing fine.


I can perfectly see my files/folders in the app – but access for playing is denied in my office. If I combine livingroom with office I can play the files in the office – but I can not start music from files in the office.


On my NAS I have 5 different main folders with files and it is all the same. Will not play in office but other zones are playing fine.


All systems are updated and I have rebooted computer, iPhone, modem, router, server, Play:5’s.


Can someone help me?





Best answer by sjw 7 May 2023, 15:20

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

56 replies

Userlevel 2
Badge +2

Add me to the list of grateful users… I have a mix of newer and older Sonos products, and this has been driving me nuts! Thanks


Thank you VERY much @sjw you are a super star.

I had the same issue, that Sonos iPad app suddenly started to report “access denied” when attempting to play music from my music library on my Synology NAS. Added “unix extensions=no” to the “smb.conf” of my Synology NAS DS218 solved it for me, and my old Sonos S1 system now works again.

Curious @sjw, how did you figure out this was the solution??

Userlevel 2
Badge +2

aargh.. it came back. checked smb.conf and line is still there, however.

Any thoughts

p.s. It CAN see the file! It offers it! :-)


when i got my new synology nas (never had issue with old one apart from it died), it took me ages to sort out the smb for s1 vs s2 was fine straight off.

now is denied again even though settings are as detailed. why cant sonos fix this as clearly a big problem...and sorry i dont understand the access via SSH >use PUTTY

I have a problem with the SJW mod to smb.conf file. If you reboot the NAS (DS218+) the file reverts to the previous version. So I still have a problem whereby the Play 1 works correctly but access is denied for my Connect. They both work if grouped together (sometimes).

Yay! Thank you!

It worked, but if you have trouble, please check your spelling. 

It didn’t work the first time and when I went back to check the file, I had written “unit extensions=no”

That will not work.