Answered

Use ROAM or MOVE as Bridge from Bluetooth Turntable

  • 23 April 2021
  • 22 replies
  • 1473 views

Userlevel 2

I am considering buying a Bluetooth turntable in order to revisit some dusty old vinyl. I am particularly interested in the Project T1 BT.

I do not want to connect any additional cabling into the turntable.

I only currently have Wi-Fi SONOS speakers in my system and was hoping that I could buy either a MOVE or ROAM bluetooth speaker to connect to the turntable and additionally use as a ‘bridge’ to enable playing of the vinyl on my other wi-fi only SONOS speakers. Can anyone confirm if this is possible to mix output via both bluetooth and non bluetooth SONOS speakers?

Thanks 

 

icon

Best answer by airforceteacher 23 April 2021, 16:14

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

22 replies

Userlevel 6
Badge +15

Roam will absolutely do this - I was listening to Youtube videos on my iPad, via Bluetooth to the Roam, bridged to Play:1 speakers  within an hour of getting the Roam. According to other posters on this board, the Move cannot do this due to a different antenna.

 

 

Userlevel 2

Thanks…..I think I keep seeing what appear to be different responses to this. I wouldn’t really use the ‘portable’ element of the ROAM and would only really use it for this ‘bridging’ purpose within range of my home wi-fi….so good to hear that it should work.

Userlevel 6
Badge +15

It’s the primary reason I bought the Roam - I already have the Move.

Has anybody actually gotten this to work?  I have Roam connected by Bluetooth to my turntable and have other Sonos grouped with the Roam, but when playing my turntable it only plays through Roam and does not recognize groups. Any help figuring this out would be much appreciated (if it is truly possible)

Userlevel 7

Has anybody actually gotten this to work?  I have Roam connected by Bluetooth to my turntable and have other Sonos grouped with the Roam, but when playing my turntable it only plays through Roam and does not recognize groups. Any help figuring this out would be much appreciated (if it is truly possible)

Yes, it works. Follow these steps:

https://support.sonos.com/s/article/5048?language=en_US

 

Userlevel 2

I can connect Roam to a Bluetooth turntable and then group to other (non Bluetooth) Sonos speakers via Airplay  - but I often encounter lots of sound dropouts when doing this (usually on the non Bluetooth speaker). 
 

Has anyone else else had / solved this problem?

I can connect Roam to a Bluetooth turntable and then group to other (non Bluetooth) Sonos speakers via Airplay  - but I often encounter lots of sound dropouts when doing this (usually on the non Bluetooth speaker). 
 

Has anyone else else had / solved this problem?

I don’t understand where Airplay comes into this? You should be playing the TT to Roam using Bluetooth, then open the S2 Sonos App (whilst connected to your WiFi) to see the Roam playing in the Rooms ‘System’ tab and then just group the Roam with your other Sonos Rooms to also play the TT audio (in sync) on those other rooms. Airplay has no role in the process.

Userlevel 2

That is what I am doing - using the group function….I thought it (happened via Airplay…..obviously not). 
 

When doing so I get drop out on the non Bluetooth speaker (Sonos One or Five). 

I don’t get drop out when Roam is not in the group. 
 


 

That is what I am doing - using the group function….I thought it (happened via Airplay…..obviously not). 
 

When doing so I get drop out on the non Bluetooth speaker (Sonos One or Five). 

I don’t get drop out when Roam is not in the group. 

 

The Roam has to be in the group as it is the device receiving the Bluetooth audio? … it’s possibly the  Bluetooth signal then between the TT and the Roam put them within three feet of each other - also try this … 

Try a different 2.4Ghz WiFi channel on your router as a Bluetooth signal uses that band. I suggest trying fixed non-overlapping channel 1, 6 or 11 and set the channel width to 20MHz.

If using a SonosNet signal also set that to a completely different channel than the one you set for the router and see if that solves your drop-out issues.

That is what I am doing - using the group function….I thought it (happened via Airplay…..obviously not). 
 

When doing so I get drop out on the non Bluetooth speaker (Sonos One or Five). 

I don’t get drop out when Roam is not in the group. 

 

The Roam has to be in the group as it is the device receiving the Bluetooth audio? … it’s possibly the  Bluetooth signal then between the TT and the Roam put them within three feet of each other - also try this … 

Try a different 2.4Ghz WiFi channel on your router as a Bluetooth signal uses that band. I suggest trying fixed non-overlapping channel 1, 6 or 11 and set the channel width to 20MHz.

If using a SonosNet signal also set that to a completely different channel than the one you set for the router and see if that solves your drop-out issues.

Hi Ken,

I have the exact same skipping problem as cheese1947 (without the airplay confusion) when using my Roam to bridge from my Bluetooth turntable to the wifi speaker room.  I've tried setting all my Sonos speakers to reserved DCHP IP addresses, as well as setting my 2.4GHz channel to 1,6 and 11.  None of it changed anything. The roam plays the music smoothly, but all the other speakers skip intermittently every 10-20 seconds.  Any other ideas?

@Erasers

How many other speakers are you grouping with the Roam? I appreciate you have tried different WiFi channels, but maybe also try the following…

  • Set the 2.4Ghz band on your router to use a channel-width of 20MHz and if that doesn’t improve things maybe try…
  • Wiring just one of the other ‘grouped’ speakers to your Router - that will switchover your main Sonos system to use SonosNet (let the system settle for 10 minutes after doing this) and then goto "Settings/System/Network” and set the SonosNet channel so it is at least 5 channels away from your chosen Router channel. So if you have set your router to use channel 6 (just as an example) then set your SonosNet channel to either 1 or 11. 

Perhaps see if doing either or both of these suggestions improves things for you.🤞

If you do the second bullet point, make sure you ‘start’ the group and playback from the wired speaker, which forces it to be the ‘group coordinator’ for that stream. 

@Ken_Griffiths @Airgetlam 

Thanks for the quick responses guys!

The bandwidths were already set to 20Mhz, so I didn't pursue that suggestion.

As a test, I set up a single play:1 speaker wired to my router which is upstairs from the Bluetooth setup. I then set the SonosNet to channel 11 and my router to channel 1.  Tried again and let it run for 10 minutes, still no better though.

I'm starting to think it's a wifi signal strength issue.  Never had an issue with other wifi devices downstairs, but I guess other playback mediums would buffer more?

Next test I'll buy a long cat5 cable and run it downstairs to see if the sonosnet runs smoothly from there.   I assume it emits from the play:1, right?

@Ken_Griffiths @Airgetlam 

Thanks for the quick responses guys!

The bandwidths were already set to 20Mhz, so I didn't pursue that suggestion.

As a test, I set up a single play:1 speaker wired to my router which is upstairs from the Bluetooth setup. I then set the SonosNet to channel 11 and my router to channel 1.  Tried again and let it run for 10 minutes, still no better though.

I'm starting to think it's a wifi signal strength issue.  Never had an issue with other wifi devices downstairs, but I guess other playback mediums would buffer more?

Next test I'll buy a long cat5 cable and run it downstairs to see if the sonosnet runs smoothly from there.   I assume it emits from the play:1, right?

How do things work if you set aside bluetooth and just use an audio source from the Sonos App to play to the exact same group? I’m just wondering if it’s the device sending the Bluetooth audio that’s not managing to keep up - maybe also try bringing the BT device closer to the Roam (within 3 feet) and try another device (if possible) that may save you running lengthy cables, which may not make any difference anyway. So maybe try other things before resorting to that option.

@Ken_Griffiths  Great suggestion!  Ok so, the roam has throughout this process been inches from the Bluetooth turntable that I'm trying to get working, so I don't think that's the issue.  For your other troubleshooting question, I disconnected my phone from wifi and streamed music to the roam, which ran smoothly.  Then used another phone to bridge from the roam to my beam over Wi-Fi and had skipping again.

So I'm thinking it's the WiFi connection, going to try bridging over SonosNet all in the same room tomorrow with a long cable, will let you know how that goes.

@Ken_Griffiths shoot, so the cable SonosNet solution didn't work.  How do I know if it's creating the SonosNet though?  Wondering if I'm missing a step there beyond just plugging in the network cable and adding it to the Roams group.

I did a speed test on the 2.4G network and it's running at about 62mbps, while the wired is running at 94, should be lots for music.

Im at a bit of a loss here currently, any thoughts?

 

@Erasers

If you put the Roam in WiFi mode instead of Bluetooth and group it with your speakers does that play okay with a different playing audio source? How many speakers/Sonos Rooms are you grouping with the Roam?

Have you tried sending Bluetooth audio from a mobile device, rather than the turntable my thoughts are the turntable audio is having a hard time keeping up - you may have to try the TT using a line-in device instead of Bluetooth, perhaps, as that way there are different audio buffer sizes you can set, which are not available to you via a Bluetooth connection.

@Ken_Griffiths I've just been grouping with one other speaker (play:1).

When I play audio purely over wifi, starting with the roam, no issues.

When I play audio from a different Bluetooth source (my mobile) and bridge to the same speaker it still skips.  So this makes me think it's not the TT.

Should I be grouping more speakers for my tests?  What's the difference between a 'group' and a 'room' from a network perspective?

A ‘room is one of these, with or without Sub:

(1) A stand-alone speaker 

(2) A (stereo) ‘pair’ of speakers 

(3) A bonded HT setup 

A ‘group’ is where you play the same stream to more than one ‘room’.

If I ‘group’ my kitchen, 2 ‘pairs’ of Sonos Ones with a Roam, then that’s 3 Rooms grouped, but 5 speakers in total and I can stream Bluetooth to that group from my iPad Pro with no noticeable issues, but I don’t have a TT to test here .. My Kitchen is 12 feet square and there’s a speaker in each corner and the Roam sits on a worktop in the middle of the room next to the iPad, but I am running all on my WiFi setup rather than SonosNet.

I understand you have tried both WiFi and SonosNet that’s what made me think it might be your turntable, but if it’s  the same with other audio sources, then it might be interference, so perhaps try different SonosNet and/or WiFi channels using non-overlapping channels 1, 6 or 11. Ensuring the same channels are not being used by both your WiFi and SonosNet.

Hope that helps.

To provide some closure to this thread for anyone following along later.  I've deduced that the issue was largely due to strength of wifi signal to the Roam.  

The Bluetooth connection appears to be quite strong between the roam and the turntable as long as line of sight is maintained, as I moved the roam around my apartment, the skipping issue occured more frequently in areas further from the router.

Keep in mind I have other Sonos speakers in many of these areas which work fine for other music streaming, but for whatever reason the roam isn't great at it when bridging.

So, I've got the roam on the other side of the room now, much improved, still occasional skips.   Will probably attempt to fine tune with router settings etc to try and get it perfect at some point here.

@Ken_Griffiths I still haven't been able to get smooth playback.  The above feedback was a bit of a false positive as the skips are still driving us crazy, not worth even playing a record currently. 

I've spent hours fiddling with various combinations of wifi settings, I moved the router into the same room, no change.  I set up a spare router to confirm it wasn't an issue with the router.  I can confirm the Bluetooth runs smoothly to the roam, but whatever the Bluetooth source is, the skipping occurs on all other speakers when the roam bridged to the other speakers via wifi.

So, the Bluetooth works well, and the wifi works well.. I can only conclude at this point that it's an issue with this particular roam or even roams in general for this use.

A I missing something here or is it time to look into my warranty options?

Warranty is of course always an option open to you to consider and here is the LINK to Sonos customer support if you do decide to pursue that. 

In your last post I see you have mentioned different things you have tried with your network/moving router etc; but you haven’t mentioned trying an alternative audio source - something other than your TT to perhaps eliminate that device as being a part of the issue.

If you stream Bluetooth audio from a mobile device, for example, does that work for you on the Roam? If not, then I would perhaps certainly speak to Sonos Support.  If that and perhaps other sources do work however, then maybe see what your TT support desk have to say about the matter, as there maybe things they can perhaps suggest too.

The only other option is to look at using a line-in audio connection to the Sonos system instead of a Bluetooth connection, as discussed previously.

HTH