Sonos One will not connect to my Synology NAS

  • 25 November 2018
  • 5 replies
  • 1680 views

I cannot connect my SONOS to my NAS where all my music library is siting. I have tried many options:
"Manage Music Library" - > "Music Library Setup" -> "Add new Share" -> Enter static IP address, or enter \\myNASname\music, or enter "Music", or many other options. Nothing works. I have also downgraded security to SMB1.

I am using Windows 10, and am trying to connect Sonos from my iPhone. The NAS is a DS218+. As far as I can tell, the whole music library is shared.
I'm a bit at a loss, any help most welcome.

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

5 replies

Can you access your music share from windows? In case you need to enter your credentials it means your Sonos also need a username/password before it can access the share.

I just added my NAS share to my Sonos One without any issues, but before the One could read all the music I needed to enter my NAS username and password (special created for my One) and grant the NAS account access to the (read only) share.

Maybe this Synology link will help:
https://www.synology.com/en-global/knowledgebase/DSM/help/DSM/AdminCenter/file_share_privilege

Or this one from Sonos:
https://support.sonos.com/s/article/78?language=en_US
Jicho thanks, yes I can access the music share from my laptop fine. I just need to log into the NAS.

I did share my music file, although I am not sure whether they are to be shared as "local user" or as "system internal user". Either way, did you actually create a (local or system internal) "SONOS" user?

As far as I can tell, I have no issue with the SONOS requirements.
I've added a user under Control Panel > Users > Create and called it "dj-sonos". During the creation the user is added to the group users (System default group). And under persmissions I've granted read access to my music share and under applications I revoked all access accept File Station and Audio Station.

In images (after creating the account) is looks like this:

Usergroups



Permissions



Applications



Or... you can set the right from the music shared folder settings:



Oh... one last thing... I'm accessing my NAS from the Sonos on IP address.

Your DS218(+) should work for 100%. I'm owning a 218+ and has, as said before, no issues.

Hope this helps a little.
Thanks Jicho: I tweaked the whole thing back from scratch following your instructions, and have now reached success!!!
Thanks v much
That's good news, glad I could help :)

Enjoy listening to your Sonos!