Question

unable to join local network


Userlevel 3

How do I fix “Sonos needs local network access for setup. In iOS settings, tap Local Network, then return to the Sonos app.”
I open the settings and local network is already ticked, I have turned it off and on again I have deleted the app and nothing seems to work 


107 replies

Userlevel 1
Badge

Sonos just updated the app, and I can now see new speakers, but it still won’t allow me to connect to the product or access existing products due to “No local network access”. Problem still needs to be fixed!

Sonos just updated the app, and I can now see new speakers, but it still won’t allow me to connect to the product or access existing products due to “No local network access”. Problem still needs to be fixed!

In that case, try a hard shutdown of your iPhone and then go back and try to add them one at the time. Worked for me anyway.

It looks like the app updated itself again and im allowed to access bluetooth however it doesnt detect my product and if i click on add speaker component then it will say the typical local network problem. any solution yet ? or will sonos just keep messing up …

Userlevel 1
Badge

Sonos just updated the app, and I can now see new speakers, but it still won’t allow me to connect to the product or access existing products due to “No local network access”. Problem still needs to be fixed!

In that case, try a hard shutdown of your iPhone and then go back and try to add them one at the time. Worked for me anyway.

I did this. Not letting me add any products. It says it needs local network access to add products.

My Sonos won’t work either. Same error!!!!!

I have the exact same issues this is ridiculous ...spent hours trying to connect my speakers

Userlevel 1

I called Sonos about this. Btw, there was an estimated 20 minute wait but i had to wait almost 90 minutes to speak with someone. They said they're aware of the issue because people have reported it. They said they can't promise when it'll be fixed and that “it could take a few days to a week to a month.” They said this is mainly affecting iPhone Pro users and recommended that i use another iOS/Android phone or tablet and try there. I don't have another mobile device so this was pointless, but nevertheless, someone on this chain said they're running into the same issue trying to add a device using their iPad, so who knows. This is unacceptable and a problem im sure could be fixed quickly. This thread was created days ago and nothing has changed. How do we raise this to a high level issue for them?

 

Userlevel 2

I called Sonos about this. Btw, there was an estimated 20 minute wait but i had to wait almost 90 minutes to speak with someone. They said they're aware of the issue because people have reported it. They said they can't promise when it'll be fixed and that “it could take a few days to a week to a month.” They said this is mainly affecting iPhone Pro users and recommended that i use another iOS/Android phone or tablet and try there. I don't have another mobile device so this was pointless, but nevertheless, someone on this chain said they're running into the same issue trying to add a device using their iPad, so who knows. This is unacceptable and a problem im sure could be fixed quickly. This thread was created days ago and nothing has changed. How do we raise this to a high level issue for them?

 

They released an update today, I updated my app, had to log out and log back in and the issue was resolved for me. Good luck 

Can’t play a single one of my eleven Sonos speakers. This system keeps getting more and more frustrating to (try to) operate. 

Userlevel 1

I called Sonos about this. Btw, there was an estimated 20 minute wait but i had to wait almost 90 minutes to speak with someone. They said they're aware of the issue because people have reported it. They said they can't promise when it'll be fixed and that “it could take a few days to a week to a month.” They said this is mainly affecting iPhone Pro users and recommended that i use another iOS/Android phone or tablet and try there. I don't have another mobile device so this was pointless, but nevertheless, someone on this chain said they're running into the same issue trying to add a device using their iPad, so who knows. This is unacceptable and a problem im sure could be fixed quickly. This thread was created days ago and nothing has changed. How do we raise this to a high level issue for them?

 

They released an update today, I updated my app, had to log out and log back in and the issue was resolved for me. Good luck

 

This last update did not resolve my issue. I just deleted + reinstalled the app and am still running into the Local Network message when i try to add a device.

Userlevel 1
Badge

I called Sonos about this. Btw, there was an estimated 20 minute wait but i had to wait almost 90 minutes to speak with someone. They said they're aware of the issue because people have reported it. They said they can't promise when it'll be fixed and that “it could take a few days to a week to a month.” They said this is mainly affecting iPhone Pro users and recommended that i use another iOS/Android phone or tablet and try there. I don't have another mobile device so this was pointless, but nevertheless, someone on this chain said they're running into the same issue trying to add a device using their iPad, so who knows. This is unacceptable and a problem im sure could be fixed quickly. This thread was created days ago and nothing has changed. How do we raise this to a high level issue for them?

 

They released an update today, I updated my app, had to log out and log back in and the issue was resolved for me. Good luck

 

This last update did not resolve my issue. I just deleted + reinstalled the app and am still running into the Local Network message when i try to add a device.

Same with me. It can now detect my devices after the update, but I still can’t connect or add new devices because of the no Local Network access wall. Core issue not fixed.

Sonos just updated the app, and I can now see new speakers, but it still won’t allow me to connect to the product or access existing products due to “No local network access”. Problem still needs to be fixed!

In that case, try a hard shutdown of your iPhone and then go back and try to add them one at the time. Worked for me anyway.

This also worked for me! I deleted the app, Added it again and it still didn’t work. Shut down my iPhone and it has finally come up for me. 

Userlevel 1
Badge

Sonos just updated the app, and I can now see new speakers, but it still won’t allow me to connect to the product or access existing products due to “No local network access”. Problem still needs to be fixed!

In that case, try a hard shutdown of your iPhone and then go back and try to add them one at the time. Worked for me anyway.

This also worked for me! I deleted the app, Added it again and it still didn’t work. Shut down my iPhone and it has finally come up for me. 

Have deleted the app multiple times, and restart phone multiple times. Sonos app still can’t get Local Network access however.

Userlevel 1

Same issue here, HELLO Sonos! Can’t add any speaker back to the system fix it now

Userlevel 1

Same issue (no recognition that the network radio button is on within the app controls on iPhone 15), and reported it through the help chat (with a human not a bot). He could not help but said that engineering is working on the fix. If anyone knows a work-around, please let us know here. Thank you.

On my iPhone 14 it wasn’t working either but on my older iPad, it is working and I was able to find my new Move. Now the iPad app is also stuck in some kind of loop of updating the Move while informing me I am not the owner and should login, while I already am. 

I have the same issue as well - after update app - I’m cut off from my system

Userlevel 1

I have solved my issue with my new Move and the Sonos IOS app (I had also problems with log in as system owner). I have managed to solve it by using the Sonos Mac OS app. I guess also the Windows app will work. 

Got the system up and running in 5 minutes after 2 hours struggle with the mobile app.

I can imagine not everybody has a Mac or Windows PC available but it works.

How do I fix “Sonos needs local network access for setup. In iOS settings, tap Local Network, then return to the Sonos app.”
I open the settings and local network is already ticked, I have turned it off and on again I have deleted the app and nothing seems to work 

SONOS customer services piece of *. fix your * problem now. It’s unbearable.

 

*Moderator Note: Modified in accordance with the Community Code of Conduct.*

Userlevel 1

HOW is this not resolved

Badge

From what i can see from others… maybe some specific iPhone models are currently having that issue, how bout try using other phones you may have (or from a friend or relatives)

I used and iPad mini and worked fine, some how I had the same problem here with my iPhone but switched to an iPad and worked perfectly 

This issue has been INCREDIBLY FRUSTRATING…Thankfully I saw someone mention on this thread something about an “IPad work around”. So I took my iPad Pro and reset and re set up with my iPad and then since it shares info with my iPhone, it now works with my iPhone. Sorry if you don’t have an iPad or some other Apple product to help use the work around but those who do, might want to try it.

Same issue! Sonos literally create the worst software I have ever encountered. Constant bugs, slow, laggy terrible user experience. It feels like it has been thrown together by a uni graduate. They coupled the app to the speaker system to such an extent I cant even add my device to the network and air play directly through Spotify. Speakers completely unusable. Sonos please hire people who actually understand how to build software.

IS THERE A SOLUTION TO THIS S*** WTF? 

 

Moderator Note: Modified in accordance with the Community Code of Conduct.

Had the same problem trying to add my surrounds to my beam using my iphone14 pro.  Downloaded to Sonos app onto my iPad and it worked!

Reply