Question

Sonos Play:5 Gen 2 bad WiFi card

  • 3 January 2021
  • 7 replies
  • 80 views

I've tried everything that everyone else has tried, but it's just dead. The app finds it and I get up to the point where it tells me it’s switching over to its own wifi connection, then it fails. I’ve tried it a dozen times. I’ve tried direct to the router using two different network cables in case I had a bad one. I’ve rebooted the router, the modem, the unit the phone several times. I’ve deleted the app twice and reloaded it. All my other sonos devices have no problems.

I’ve tried calling support three different times on three different days and each time I was put on hold for over a half an hour or longer before they disconnected or hung-up on me. I even got up early in the morning (PST) last week hoping to get in a short line but the same thing happen. Put on hold then disconnected. I even tried their chat but its not working on their site. It's a shame since I’m a partner in an AV company and we have installed hundreds of Sono products but I can’t even get mine to work.

it's out of warranty. Any suggestions on what to do next?

Thanks Everyone.


7 replies

Userlevel 6
Badge +15

Hello there @zestbow, Thanks for reaching out, and welcome to the community. Sorry to hear about this issue on your Sonos Play 5 Gen 2, don’t worry, I’ll assist you with this concern. We can determine if a Sonos Play 5 Gen 2 has a bad wifi card through diagnostics, I’ll ask you to submit a diagnostic report to investigate further what could be causing this issue and if it’s a bad wifi card. You may reply to the thread with the confirmation number to assist you with this issue.  

Let us know how it goes and we're here to answer any further questions you have.

If you are trying to setup the Play:5 device, involving Apple WAC (Wireless Accessory Configuration) using an iOS mobile controller ad-hoc WiFi connection, then there have been some issues with iOS 14.2. So you may want to try with an earlier, or later version of iOS, or any recent Android device.


If using iOS, I would also suggest temporarily switching off ‘Private Address’ in the WiFi network connection on the mobile device, then re-enable it after setup.

 

Also ensure that the relevant WiFi has 802.11b/g modes enabled.

 

A further consideration is to try a different ethernet cable/router port, if leaving the device wired during setup following factory reset.

 

Ah sorry @Simon B you beat me to it. 👍 

Thank you simon

Here you go

202196618

Userlevel 6
Badge +15

Hello there @zestbow, thanks for the update and for sending a diagnostic report. Upon checking, It only shows a controller diagnostic, So we can’t see the actual status of the Sonos speaker. Kindly try the advice of @Ken_Griffiths to check if that will work for you. If not, then we’ll take this further.

Keep us posted on how it goes and we're here to answer any further questions you have.

Hi Simon, sorry I was out of town. Yes I followed your advice and did exactly what Ken did and it did the exact thing. It started to work then it lost all signal. Even direct connection via a ethernet. I disconnected all my sonos devices and unplugged them. Remove the app. Started with version one of the app all the way up and no change. 

Userlevel 6
Badge +15

Hi @zestbow, thanks for the update. seems like we can’t get a consistent diagnostic report of your Sonos system because the first one that you’ve sent only shows controller diagnostics, which means the speaker is not connected to the network. If it’s possible if you can resend a diagnostic report when the system is up so that we can check further. Thanks.

Let us know what you have in mind with the advice above.

Reply