Question

Play Next on S2 ios app


Userlevel 1
Badge +2

Perhaps i’m being dim here, but has Play Next been removed from the S2 app?

In S1 I could press and hold a track and get a Play Next option, but that no longer works. has it been moved or removed?


13 replies

Hi.  Just scroll the list down

Userlevel 1
Badge +2

Hi.  Just scroll the list down

Tried that, still no option to Play Next. Pressing “More” brings up another box, but still has no Play Next option

 

You appear to be trying to do this from the queue, rather than from somewhere where you would normally select music to play, such as in the Browse or Search screens.

Absolutely nothing has changed here.

Userlevel 1
Badge +2

You appear to be trying to do this from the queue, rather than from somewhere where you would normally select music to play, such as in the Browse or Search screens.

Absolutely nothing has changed here.

I’m going to take some convincing on this one :relaxed: . I think I’ll have to find someone still on S1 to check - I’m sure I've done this before (although I do remember also manually moving a track’s position in the queue so it played next!)

You’d think it was years ago, not just a few weeks! Thanks for the reply, regardless

That context menu refers to a track in the queue. AFAIK there’s never been a ‘play next’ option there. If you want to play a queued track immediately then simply tap it. If you want to rearrange the queue then use the Edit option. 

S1 app. Long press on track in queue

 

S1 app. Long press on track in search

 

It doesn't even make logical sense to offer a Play Next option on a queued track.

You are clearly remembering the second scenario and thinking it applied to the first.

But I won't argue any further. 

Exactly the same issue here although I’d go much further:  Sonos2 is much worse and I’ve yet to find any advantage. I wish I’d never upgraded.

 

I think I have, however, solved this issue and it’s nothing to do with the queue.
 

The first screenshot below is not the queue, it’s from a search for an album and then selecting a track either by long press on the title or the three dots on the right.
I can’t get anything onto the queue by that route.
Except that What felt like entirely randomly I could when mysteriously the options are different such as when I do exactly the same thing for the next track in the same album as in the next screenshot.

I think the clue is “my Sonos” although I have no idea what or where that is… try adding to my Sonos and then selecting again and you then get the play next option. (Last screenshot)
 

Just in case you’re wondering I can separately get to the queue and edit it - this is absolutely not the queue and I was not playing any of this album when taking the screenshots.


Any suggestions of what I’m describing or what my Sonos is would be gratefully received.

 


 

 

 

Nothing related to this has changed between S1 and S2. At least, nothing functionally - fewer options are visible before you scroll. 

Tap the star icon at far left of navigation bar to see My Sonos. I don't think it's relevant to the issue though. 

@GingerNinja . Not much of what you have written is correct I'm afraid.  Your screenshots are of the same scrollable list with different bits visible.  There is no connection to My Sonos. Except of course that when a track is already in My Sonos you don't get an option to save it again. 'My Sonos' is essentially Favourites and Playlists 

Thanks

Ah - the penny drops. What I’m saying is correct but you’re right there is a MUCH slicker way to achieve the same thing that doesn’t involve two steps - The pick list of what to do with the track is scrollable so from my first screenshot I can scroll down to find play next.  What I’m describing is that the ‘add to my sonos’ having disappeared from the list (because it’s already been added) just shortens the scroll list so the ‘play next’ option is already visible.

Obvious once you’ve done it but clearly catching some users out.

Yes you have got it now!  And you certainly aren’t the first to be caught out like this.

In this particular thread the OP’s issue turned out to be something different - he was looking for a ‘Play Next’ option in the queue.  But there are a few other threads where the user didn’t realise that the options were there when browsing music, just not immediately visible.

Reply