Why is Alexa responding on Echo but not Sonos One?

  • 7 January 2018
  • 2 replies

Sonos One and the Echo are both set up through the Alexa app, but when I say her name she only responds on the Echo. If I ask her to play something, she'll also only play it on the Echo - is there any way for her to automatically play whatever I've asked her to on the Sonos One at the same time so that they're always in sync? Otherwise is there any point in having the Echo, since if I can get her to respond on Sonos I may as well just use that since the speaker it's so much better...

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

2 replies

Userlevel 7
Badge +20
Amazon servers will choose the device that received the strongest voice command and mute the other devices, so there is little benefit in having both in the same room. (If you want to use the Echo for commands not currently supported by the Sonos One then I suggest you change the Wake Word in the Alexa App>Settings>{Your Echo Dot} to 'Computer' - then Alexa will trigger the Sonos One and Computer will trigger the Echo Dot.

If you want the music to output on the Sonos player and the command is received by the Echo Dot, then you need to include the Room Name of the Sonos Play One. e.g. 'Alexa, Play soft jazz on {Room Name}'
I have the same problem, and my units are in different rooms. I linked them in a group on the Alexa app and ever since I've had the issue of commands said to the Sonos are processed on the echo dot in a different room. Also, the group thing doesn't work - I cant play music on all speakers, nor can I tell Alexa to play in the other room.