Why does Alexa on Beam say something is going to play but nothing does?

  • 10 November 2021
  • 3 replies
  • 41 views

Sometime ago now, Alexa stopped playing anything that was asked, but said it was going to play. Choose any radio station or specify, e.g. “Play Heart FM”, “Playing Herts/Beds/Bucks from Global Player”, then nothing.

It seems this is a common occurence but nothing has resolved the issue so far. There is no issue weith my network, WiFi, cables, router, Firewall and so forth. I have tried off and on too. I have laso disable the Sonos skill and re-enabled, probably many other things too.  All with the same results. Someone somewhere knows what the fix is I am sure. For now I will gladly receive any suggestions.


3 replies

Maybe the sharing agreement token has dropped for some reason… try removing the Sonos Skill from the Amazon Alexa App - Also check these couple of things:

  1. Sonos products/rooms are not duplicated in the Alexa App device list.
  2. Sonos products/rooms do not have names that are identical to any other group, or other smart-home device in the Alexa App device list.

Then reinstall the Sonos Skill in the Alexa App and allow it to rescan for your devices. Then try again to see if that resolves your issue.

Userlevel 7
Badge +20

Hi

This is a copy of an old post sorry it’s not a short list:

 

The integration between Sonos and Amazon can sometimes throw up annoying, confusing and sometimes completely random issues.  A very large proportion of these issues can be resolved by some very simple tasks.  These have been documented across multiple posts and have remained fairly consistent since the functionality was released.  However, some of my earlier posts are now obsolete due to changes within the navigation and terminology of both the Sonos and Alexa Apps.  As a result, I have compiled an updated set of steps to help users resolve the most common issues.  However, before we start please don’t get phased by the scale of the steps below, they are not all required! I have tried to list these with the most common and easiest solutions first building to a complete reset.  But before we start, if you are experiencing issues with Alexa, then please check for any outages on this page first: Sonos Status

 

Duplicate device names – Although Amazon states that Alexa has the ability to know the different actions for different device types, my experience is Alexa prefers that names for Devices, Groups and Scenes are unique,
1.1/ Please open up the Alexa App and press the ‘Devices’ button in the bottom right of your device.  You’ll need to make a note of any duplicate names, a common mistake is to have a Room and a Device with the same name. I personally use the naming standard Room Name + Device type. e.g. Kitchen Sonos, Kitchen Echo Dot, Bedroom Sonos, etc. Although this would appear to make the voice control of devices more complicated, the use of Groups, removes the need to name these specific Device names in most voice commands.  Here is a link to my naming standards:
https://en.community.sonos.com/amazon-alexa-and-sonos-229102/best-practices-for-naming-of-devices-6819283/index1.html;
1.2/ You can then change them in the source app. e.g. Use the Sonos App to change the name of Sonos players.
1.3/ In the Alexa app, select the Alexa Icon in the centre of the row of Icons at the bottom of the screen and ask ‘Alexa, Discover Devices’.

 

Please Retest


Account Linking - Some form of Account Linking or Authorisation has not completed successfully. There are a number of causes for this and it's best to try these steps one at a time and test before moving on to the next step if the problem persists:
2.1/ Open the Alexa App>Skills>Your Skills>Sonos and 'Disable' followed by 'Enable';
2.2/ If you have multiple Amazon accounts logged into different Apps on your device, this can confuse the Amazon Authorisation. Please ensure that you log out of all Amazon related Apps and accounts and then complete step 2.1 again;
2.3/ If the problem still persists, please logout of all Amazon accounts then select the Alexa App>Skills>Your Skills>Sonos and 'Disable. Now power down all Sonos devices for at least 10 secs, allowing for any wired devices to boot before booting the remaining Sonos players. Now log back into the Alexa App>Skills>Sonos and 'Enable'

 

Please Retest


Duplicate IP Address – Please see my Post here: en.community.sonos.com

 

Please Retest

Thanks Ken, it seemed to be the duplicate and/or superfluous Sonos devices. So thanks for your help as I problably wouldn’t have got there as the Alexa capability is only ever used stand-alone That is to say, it’s not used to control multi-room Sonos, just very minmally on the Sonos Beam, “play radio”, “what’s the weather”, “volume up 5” etc. I would have seen (if I’d even looked) the Sonos devices and probably ignored them as I only wanted to use the one with Alexa.

Reply