Answered

What command to use? Switching back to TV

  • 7 October 2017
  • 8 replies
  • 4630 views

Userlevel 1
Badge +1
Set alexa up. I can play music by command through my living room speakers. But what command do you use to go back to playing the TV audio?
icon

Best answer by Ryan S 9 October 2017, 19:35

Thanks. I couldnt find anything myself. Was hoping there would be something i was missing. This really needs to get added. Im certain they would have discovered this issue during the beta.

It's definitely something on the list that we'd like to sort out.

For now, if you're using Autoplay on your PLAYBAR, just stop playing audio on the TV for about 12 seconds or so. You can turn the TV off, or maybe mute it (if the remotes are separate). That should do the trick to switch back to the TV source without grabbing your Sonos controller.
View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

8 replies

There isn't currently a command to switch inputs on Sonos using Alexa
To add to my unhelpful answer, and hopefully make it more helpful, you can find the current list of commands for voice interaction here:

Alexa Details
Userlevel 1
Badge +1
Thanks. I couldnt find anything myself. Was hoping there would be something i was missing. This really needs to get added. Im certain they would have discovered this issue during the beta.
Userlevel 7
Badge +26
Thanks. I couldnt find anything myself. Was hoping there would be something i was missing. This really needs to get added. Im certain they would have discovered this issue during the beta.

It's definitely something on the list that we'd like to sort out.

For now, if you're using Autoplay on your PLAYBAR, just stop playing audio on the TV for about 12 seconds or so. You can turn the TV off, or maybe mute it (if the remotes are separate). That should do the trick to switch back to the TV source without grabbing your Sonos controller.
Just use the command “Alexa, stop.” This shuts off the music completely. Turn up the volume using your TV remote control and you’re good to go. Took me a few trial and errors to figure it out, but it works like a charm. But just to clarify - I have the Playbar connected to my TV with auto play. Hope this helps!
Userlevel 1
Badge +1
Im using a play bar and to play3s. I have a harmony remote set to control the volume of the play as the input is directly from the source and the source has no volume control. I also use alexa to control all devices including the sonos. To help with solving this. I am able to have akexa stop, turn off the tv by voice command and turn the tv back on and audio input will be back on tv. If the tv was not on when i started listen to music and i give the command for alexa to turn on the tv. The music will stop playing, all devices come on and input automatically switches to tv audio input. And BTW, I love how all sonos volume goes down when you give the wake command so alexa can listen. Great!!
Im using a play bar and to play3s. I have a harmony remote set to control the volume of the play as the input is directly from the source and the source has no volume control. I also use alexa to control all devices including the sonos. To help with solving this. I am able to have akexa stop, turn off the tv by voice command and turn the tv back on and audio input will be back on tv. If the tv was not on when i started listen to music and i give the command for alexa to turn on the tv. The music will stop playing, all devices come on and input automatically switches to tv audio input. And BTW, I love how all sonos volume goes down when you give the wake command so alexa can listen. Great!!


How do you get Alexa to turn on your tv and switch inputs? I have a very similar set up.
Userlevel 7
Badge +26
There's a command that's available which should switch to using the TV audio input. With Beams, just ask: "Alexa, switch to TV." This should also work for the Playbar or Playbase, using an Alexa device, but you will need to target the device by room name: "Alexa, switch to TV on [room name]."